Project

General

Profile

Actions

Bug #5466

closed

LocalConsumer.h is missing

Added by Gary Mills almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
2014-12-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

A build with java 1.7 installed on the build host resulted in many of these errors:


/usr/java/bin/javac -g -d
/dpool/export/home/mills/Downloads/code/illumos-gate/usr/src/lib/libdtrace_jni/java/classes
-sourcepath
/dpool/export/home/mills/Downloads/code/illumos-gate/usr/src/lib/libdtrace_jni/java/classes:/dpool/export/home/mills/Downloads/code/illumos-gate/usr/src/lib/libdtrace_jni/java/src
-deprecation -target 1.5 -Xlint
/dpool/export/home/mills/Downloads/code/illumos-gate/usr/src/lib/libdtrace_jni/java/src/org/opensolaris/os/dtrace/AbstractAggregationValue.java
javac: target release 1.5 conflicts with default source release 1.7

The result of these errors was that LocalConsumer.h was not created in usr/src/lib/libdtrace_jni/java/native . The fix is to modify java/Makefile to specify `-source 1.5'. My patch file is attached.


Files

java.diff (458 Bytes) java.diff Gary Mills, 2014-12-21 10:29 PM

Related issues

Is duplicate of illumos gate - Feature #4719: update gate build environment to [open]jdk7Closed2015-04-17

Actions
Actions #1

Updated by Rich Lowe almost 7 years ago

  • Status changed from New to Closed

duplicate of #4719

Actions

Also available in: Atom PDF