Project

General

Profile

Bug #547

Installer doesn't set opensolaris.org publisher non-sticky

Added by Jon Tibble almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
Start date:
2010-12-18
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Chaos ensues...

History

#1

Updated by Julian Wiesener over 8 years ago

  • Assignee set to OI Caiman

i suppose opensolaris.org should go away instead of setting it non-sticky. als by now, update of 148 to 148+ does work fine without opensolaris.org repo

#2

Updated by Alasdair Lumsden over 8 years ago

  • Target version set to oi_151
  • Difficulty set to Medium
  • Tags set to needs-triage

After discussion during last weeks #oi-meeting, we decided we would update IPS present in oi_148 to deliver a self-deleting SMF manifest, which would set opensolaris.org non-sticky.

Updating IPS oi_148 would result in "pkg image-update" returning an error that pkg is out of date. The user would then upgrade pkg, which would set opensolaris.org non-sticky. Then an upgrade would complete correctly.

I will do a post-install SMF manifest that does this, rebuild pkg5, then pass this to release engineering to publish to /dev.

#3

Updated by Alasdair Lumsden over 8 years ago

  • % Done changed from 0 to 90

Hi All,

I've updated my self-deleting manifest to set opensolaris.org non-sticky. This should hopefully be the final build, which we can ship to the main repo.

I'd like more than 3 people to test this before we ship this /dev.

The changeset to mq_pkg-gate is here:

http://hg.openindiana.org/mq_pkg-gate/file/tip/oi-issue-547-installer-doesnt-set-opensolaris-org-publisher-non-sticky

The repo is here:

http://pkgdev.uk.openindiana.org:20547/

Here is a log of testing it (which explains what you have to do to test):

root@sandbox.thnstar.everycity.co.uk:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.openindiana.org/legacy/
root@sandbox.thnstar.everycity.co.uk:~# pkg set-publisher --sticky opensolaris.org
root@sandbox.thnstar.everycity.co.uk:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org origin online http://pkg.openindiana.org/legacy/
root@sandbox.thnstar.everycity.co.uk:~# pkg set-publisher -g http://pkgdev.uk.openindiana.org:20547/ pkg5-nightly
root@sandbox.thnstar.everycity.co.uk:~# pkg publisher
PUBLISHER TYPE STATUS URI
openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/
opensolaris.org origin online http://pkg.openindiana.org/legacy/
pkg5-nightly origin online http://pkgdev.uk.openindiana.org:20547/
root@sandbox.thnstar.everycity.co.uk:~# pkg set-publisher --search-before openindiana.org pkg5-nightly
root@sandbox.thnstar.everycity.co.uk:~# pkg set-publisher --non-sticky openindiana.org
Caching catalogs ...
root@sandbox.thnstar.everycity.co.uk:~# pkg publisher
PUBLISHER TYPE STATUS URI
pkg5-nightly (preferred) origin online http://pkgdev.uk.openindiana.org:20547/
openindiana.org (non-sticky) origin online http://pkg.openindiana.org/dev/
opensolaris.org origin online http://pkg.openindiana.org/legacy/
root@sandbox.thnstar.everycity.co.uk:~# pkg install pkg:,5.11-0.148:20110712T232715Z
Packages to update: 1
Create boot environment: No
Services to restart: 1
DOWNLOAD PKGS FILES XFER (MB)
Completed 1/1 126/126 0.7/0.7

PHASE ACTIONS
Install Phase 1/1
Update Phase 241/241

PHASE ITEMS
Package State Update Phase 2/2
Package Cache Update Phase 1/1
Image State Update Phase 2/2
root@sandbox.thnstar.everycity.co.uk:~# svcs -a
STATE STIME FMRI
...
offline* 0:39:10 svc:/system/manifest-import:default
root@sandbox.thnstar.everycity.co.uk:~# svcs -a
STATE STIME FMRI
...
online 0:39:12 svc:/system/manifest-import:default
root@sandbox.thnstar.everycity.co.uk:~# pkg publisher
PUBLISHER TYPE STATUS URI
pkg5-nightly (preferred) origin online http://pkgdev.uk.openindiana.org:20547/
openindiana.org (non-sticky) origin online http://pkg.openindiana.org/dev/
opensolaris.org (non-sticky) origin online http://pkg.openindiana.org/legacy/

As you can see, after installing the new package, it sets opensolaris.org non-sticky.

Looking forward to feedback :-)

Cheers,

Alasdair

#4

Updated by Alasdair Lumsden over 8 years ago

  • % Done changed from 90 to 70

Hi All,

DeanoC tested this on his oi_147 "supposedly updated to oi_148" machine (see http://www.pastie.org/2213307 for his package list where most packages are still 0.147 due to opensolaris.org being sticky).

Unfortunately it doesn't work; my updated pkg is for 0.148, and since DeanoC's opensolaris.org is sticky, it refuses to update it.

Since this is effectively what we're trying to fix, Trisk suggested I redo my fix for oi_147 and publish that. I will attempt to implement this at some point over the next few days.

Cheers,

Alasdair

#5

Updated by Albert Lee over 8 years ago

  • Assignee changed from OI Caiman to Alasdair Lumsden
#6

Updated by Alasdair Lumsden over 8 years ago

Updated package/pkg packages have been published to /dev for oi_147 and oi_148. Users who image-update now will get told to update pkg:/package/pkg, which will deliver the self-deleting manifest which sets opensolaris.org non-sticky.

I'm not sure if the installer still leaves opensolaris.org set sticky - this needs testing, as ultimately it's the root cause.

#7

Updated by Alasdair Lumsden over 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 70 to 100

Trisk will sort out the 151 ISO as per:

https://www.illumos.org/issues/1134

Also available in: Atom PDF