Project

General

Profile

Bug #5501

Version of sqlite included in illumos is ancient

Added by Andrew Stormont over 5 years ago. Updated over 5 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2014-12-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

It should be upgraded to v3. There are known concurrency issues with the version we're shipping.

History

#1

Updated by Igor Kozhukhov over 5 years ago

  • Status changed from New to Feedback

you can't upgrade sqlite to v3 because SVC based on V2 and can't use V3
also - you can't upgrade local SVC db from V2 to V3 automatically by upgrade

#2

Updated by Andrew Stormont over 5 years ago

I know it's going to take some work but I still think it's worth doing. We will need to come up with a migration strategy.

#3

Updated by Andrew Stormont over 5 years ago

"How to convert between sqlite2 and sqlite3 database" http://blog.mypapit.net/2012/10/1823.html

Seems simple enough.

#4

Updated by Igor Kozhukhov over 5 years ago

you can try to do it by yourself first :) with upgrade/migration procedure.
i'm not sure it will be easy for end users with more deployment
also - need more testing with new sqlite3
we have more patches for sqlite2 and it is working stable

Also available in: Atom PDF