Project

General

Profile

Bug #551

USB image fails during boot on Dell Precision M6300

Added by Gordon Ross almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2010-12-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

On a Dell Precision M6300 (a laptop) where previous OpenSolaris builds worked very well, the USB image for oi_148 has problems during boot. The kernel starts, gets as far as the initial breakpoint (boot -kdv) where I continue it, and then I see errors from either the ATA or the SCSI driver. Here are the unusual messages:

ACPI Info for \_SB_.BAT0._BIF: Converted Buffer to expected String at index 9 (20091112/nsrepair-279)
[couplemore of these, index 10, 11, 12]

WARNING: /pci@0,0/pci-ide@1f,2/ide@0 (ata4):
timeout: abort request, target=0 lun=0
[repeats several times, then]
WARNING: /pci@0,0/pci-ide@1f,2/ide@0/cmdk@0,0 (Disk0):
Error for command 'read sector' Error level: Informational
Sense Key: aborted command
Vendor 'Gen-ATA ' error code: 0x3
[ two of those, then the whole message sequence over and over...]


Related issues

Is duplicate of OpenIndiana Distribution - Bug #544: BGE driver hangs system after update to oi_148Resolved2010-12-17

Actions

History

#1

Updated by Julian Wiesener almost 9 years ago

This issue is not USB related and also not limited to this modell. /pci@0,0/pci-ide@1f,2/ide@0/cmdk@0,0 is the SATA drive in PATA-Compatible mode. Try to enable Native-AHCI in the BIOS.

I can also confirm that this issue appears with oi-148 installed on disk, oi-147 is not affected. I assume this issue is power management related and will do some tests, unfortunetly my BIOS offers no Native-AHCI mode.

#2

Updated by Gordon Ross almost 9 years ago

The bios on the Dell Precision M6300 does allow putting the SATA drive in
either ATA or EHCI mode. It was in ATA mode in my previous attempt.

After switching it to EHCI mode, I had different problems.
It looks like the machine could see the disk, but then the
built-in keyboard was non functional. Also experimented
with -B acpi-user-option=0x8 but that just hangs later.

I'm not impressed with our ACPI support...

#3

Updated by Gordon Ross almost 9 years ago

I have confirmed Julian Wiesener's statement re. oi_147 is OK.
(it has no problem on the Dell Precision M6300).

So this problem was introduced between 147 and 148.

#4

Updated by Julian Wiesener almost 9 years ago

It turns out, that the new bge driver was the problem for my system. It would be great if you can confirm this by disableing the onboard network interface in the BIOS and try a boot from the USB image.

An workarround for installed system is to copy /kernel/drv/bge (/kernel/drv/amd64/bge for 64bit kernel) from 147 to the 148 filesystem.

#5

Updated by Gordon Ross over 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Albert Lee

Turns out this was just another instance of: 544
https://hg.illumos.org/issues/544
BGE driver hangs system after update to oi_148

The same system boots fine with the io_147 drivers
(/kernel/drv/bge, /kernel/drv/amd64/bge) copied into
the oi_148 image.

#6

Updated by Albert Lee over 8 years ago

  • Status changed from Feedback to Resolved

This was fixed in a oi_148 update.

Also available in: Atom PDF