Project

General

Profile

Bug #5580

Sun Studio probably relies on the behaviour 3616 removed

Added by Rich Lowe almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
tools - gate/build tools
Start date:
2015-01-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

This is a bit of a guess, because I haven't debugged it yet.

Recently, ZFS added inline functions in header files, which means that libzpool (for eg) makes use of COMDAT to make sure only one out-of-line definition survives.

This breaks, when Studio is the primary compiler. It looks like that Studio wants us to process both name-based and GROUP comdat, whereas doing so with GCC is problematic.

Perhaps we should sniff the key symbol name for a known "COMDAT-y" name, (.section%symbol), and run both if it matches?

Perhaps I'm an idiot.

Perhaps we should just despair.


Related issues

Related to illumos gate - Bug #3616: SHF_GROUP sections should not be discarded via other COMDAT mechanismsResolved2013-03-09

Actions
Is duplicate of illumos gate - Bug #5595: libzpool won't build with a studio primaryClosed2015-02-05

Actions

History

#1

Updated by Rich Lowe almost 5 years ago

  • Status changed from New to Rejected

This is #5595

Also available in: Atom PDF