Project

General

Profile

Actions

Bug #5651

closed

Missing header file sys/fs/s5ino.h referenced in /usr/src/cmd/acct/diskusg.c

Added by Sam Zaydel about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2015-02-23
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

As far as I can tell, this header file

sys/fs/s5ino.h
does not exist in the sources, yet is being referenced by
/usr/src/cmd/acct/diskusg.c
.

Actions #1

Updated by Gary Mills about 7 years ago

Actually,all of the sys/fs headers included in this file don't exist. There's no error message because diskusg.c is never compiled. It hasn't been used since SunOS 4.1.3. It was intended for an old disk format that was part of AT&T SysV. I'll prepare a webrev that deletes this file from the illumos source.

Actions #2

Updated by Electric Monk about 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 12844f5a6e6a4f8cb472dc421b8263103c55bd43

commit  12844f5a6e6a4f8cb472dc421b8263103c55bd43
Author: Gary Mills <gary_mills@fastmail.fm>
Date:   2015-05-05T18:34:10.000Z

    5651 Missing header file sys/fs/s5ino.h referenced in /usr/src/cmd/acct/diskusg.c
    Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
    Reviewed by: Marcel Telka <marcel@telka.sk>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Actions

Also available in: Atom PDF