Project

General

Profile

Actions

Bug #5654

closed

Memory leaks in fctl module

Added by Marcel Telka over 6 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2015-02-24
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

While trying to reproduce bug #5652 (using the suspend/resume cycle) I noticed some memory leaks in the fctl module:

streams_dblk_80 leak: 1 buffer, 192 bytes
            ADDR          BUFADDR        TIMESTAMP           THREAD
                            CACHE          LASTLOG         CONTENTS
ffffff00de59f1c8 ffffff00e441cf00       2d8fd70cd1 ffffff00cd6264a0
                 ffffff00c4833508 ffffff00c57bb6c0                0
                 kmem_cache_alloc_debug+0x2e0
                 kmem_cache_alloc+0x320
                 allocb+0x9e
                 fc_ulp_linkreset+0x98
                 fc_ulp_port_ns+0x174
                 fc_ulp_login+0xf3
                 putnext+0x28f
                 strdoioctl+0x422
                 strioctl+0x58a
                 spec_ioctl+0x51
                 fop_ioctl+0x55
                 ioctl+0x9b

streams_mblk leak: 1 buffer, 64 bytes
            ADDR          BUFADDR        TIMESTAMP           THREAD
                            CACHE          LASTLOG         CONTENTS
ffffff00e3e4f000 ffffff00e3e7a640       2d8fd70c6a ffffff00cd6264a0
                 ffffff00c4833008 ffffff00c57bb600                0
                 kmem_cache_alloc_debug+0x2e0
                 kmem_cache_alloc+0x320
                 dblk_constructor+0x5a
                 kmem_cache_alloc_debug+0x14f
                 kmem_cache_alloc+0x320
                 allocb+0x9e
                 fc_ulp_linkreset+0x98
                 fc_ulp_port_ns+0x174
                 fc_ulp_login+0xf3
                 putnext+0x28f
                 strdoioctl+0x422
                 strioctl+0x58a
                 spec_ioctl+0x51
                 fop_ioctl+0x55
                 ioctl+0x9b

I'm not sure the suspend/resume cycle is relly related to this bug.


Related issues

Is duplicate of illumos gate - Bug #5512: Memory leak in ecpp(7d)New2015-01-07

Actions
Actions #1

Updated by Marcel Telka over 6 years ago

  • Status changed from New to Rejected

This is a duplicate of #5512. We do see a different stack trace just because the ecpp(7d) module was unloaded and some other victim was loaded on the same addresses.

Actions

Also available in: Atom PDF