Project

General

Profile

Bug #5721

tmpfs should support "mode" option

Added by Joshua M. Clulow about 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
kernel
Start date:
2015-03-16
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Historically, tmpfs mounts have inherited the permission from the directory they are mounted atop. The mount option could allow for this behaviour to be overridden without the TOCTOU race implied in a mount followed by a chmod.

NB: This bug mirrors Joyent OS-4044 .


Related issues

Is duplicate of illumos gate - Feature #7753: tmpfs should support "mode" optionClosed2017-01-09

Actions

History

#1

Updated by Yuri Pankov about 3 years ago

  • Status changed from New to Resolved

Duplicates #7753.

#2

Updated by Yuri Pankov about 3 years ago

  • Is duplicate of Feature #7753: tmpfs should support "mode" option added

Also available in: Atom PDF