Project

General

Profile

Bug #5753

libnsl: set_up_connection() over TCP does not adhere the specified timeout

Added by Marcel Telka almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
networking
Start date:
2015-03-26
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The set_up_connection() over TCP does not adhere the specified timeout.

Steps to reproduce (use the attached rpc-timeout.c file):

# gcc -Wall -l nsl -o rpc-timeout rpc-timeout.c
# ./rpc-timeout
Usage: ./rpc-timeout hostname [timeout]
# time ./rpc-timeout 10.0.0.99 5
clnt_create_service_timed failed

real    6m29.996s
user    0m0.002s
sys     0m0.005s
#

Note: The IP address used is the IP address of an unreachable machine.

The timeout should be about 5 seconds, but we see the actual timeout is over 6 minutes.


Files

rpc-timeout.c (482 Bytes) rpc-timeout.c Marcel Telka, 2015-03-26 02:12 PM

Related issues

Related to illumos gate - Bug #5848: TCP options are reset after failed connect()New2015-04-16

Actions
#1

Updated by Marcel Telka almost 6 years ago

  • Related to Bug #5848: TCP options are reset after failed connect() added
#2

Updated by Marcel Telka almost 6 years ago

The set_up_connection() tries three times to connect to the other party in a case the connect is unsuccessful. The first connect try is with the specified timeout, but the 2nd and 3rd attempt is with the default timeout (3 minutes) because of the bug #5848.

#3

Updated by Marcel Telka almost 6 years ago

  • Status changed from New to In Progress
#4

Updated by Marcel Telka over 5 years ago

  • Status changed from In Progress to Pending RTI
#6

Updated by Electric Monk over 5 years ago

  • Status changed from Pending RTI to Closed
  • % Done changed from 0 to 100

git commit 7e89328164e4b89906924cf4e0387ea13a77631b

commit  7e89328164e4b89906924cf4e0387ea13a77631b
Author: Marcel Telka <marcel.telka@nexenta.com>
Date:   2015-05-05T18:41:51.000Z

    5753 libnsl: set_up_connection() over TCP does not adhere the specified timeout
    Reviewed by: Dan Fields <dan.fields@nexenta.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF