Project

General

Profile

Actions

Bug #5944

closed

Bug #5943: grub fails to boot when too many boot environments are present

Related to 5943 (please merge)

Added by Josten L about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Start date:
2015-05-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

This is related to bug 5943 and includes instructions how to reproduce. I'm not seeing a way to add these reproduction instructions to that bug, so I'm creating a new bug post on how to do so.

Instructions:
  1. cd /rpool/boot/grub/
  2. cp menu.lst{,.bak}
  3. cat menu.lst.bak >> menu.list

Reboot until the issue is experienced. For me, it was when menu.lst was greater than 100K.

It's possible that the menu.lst can become so big that you cannot even boot via grub command-line; forcing a live CD boot to manually cleanup the menu.lst receiving the following error:

grub> bootfs rpool/ROOT/omnios-r151014
Error 28: Selected item cannot fit into memory

Actions #1

Updated by Josten L about 7 years ago

Repeat step 3 until issue occurs.

Actions #2

Updated by Marcel Telka about 7 years ago

Josten, there should be the Edit link on the bug page pointing to https://www.illumos.org/issues/5943/edit. You need to be logged in to see it.

Actions #3

Updated by Marcel Telka about 7 years ago

  • Status changed from Feedback to Closed

Copied to #5943.

Actions

Also available in: Atom PDF