Project

General

Profile

Actions

Bug #5964

closed

Feature #3716: Implement mkostemp() and mkostemps()

mkostemp() and mkostemps() need prototypes in stdlib.h

Added by Dan McDonald almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
lib - userland libraries
Start date:
2015-05-28
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Subject says it all. I was compiling someone else's software, and it found that we support these (probably via libtool hacks), but it failed on compilation because:

../.././libgfortran/io/unix.c: In function 'tempfile_open':
../.././libgfortran/io/unix.c:1126:8: error: implicit declaration of function 'mkostemp' [-Werror=implicit-function-declaration]
   fd = mkostemp (template, O_CLOEXEC);
Actions #1

Updated by Dan McDonald almost 7 years ago

  • Status changed from New to Closed

Duplicate of #5187

Actions

Also available in: Atom PDF