Project

General

Profile

Actions

Bug #5977

closed

Machine crash when double-tabbing through directory

Added by Graham Stephens over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2015-06-02
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

In a non-global zone (using zlogin) with zvol passed from global zone (add device), double-tabbing through the /dev directory structure to find device causes system crash.

Repeatable.


Files

crash.0 (579 KB) crash.0 Graham Stephens, 2015-06-02 08:49 PM

Related issues

Is duplicate of illumos gate - Bug #5421: devzvol_readdir() needs to be more careful with strchrClosedRobert Mustacchi2014-12-09

Actions
Actions #1

Updated by Graham Stephens over 6 years ago

I have found that using ls to list the device file causes a crash as well.

It may be that I have misconfigured zonecfg - this is new to me - but if that is the case, the system let me do it!

Actions #2

Updated by Graham Stephens over 6 years ago

It was a misconfig after all - there are several issues with the OmniOS docs.
I'm still surprised it is so easy to crash the whole system though.

Please close this bug report.

Actions #3

Updated by Yuri Pankov over 6 years ago

Could you describe what exactly you did as this should be fixed, not closed?

Actions #4

Updated by Graham Stephens over 6 years ago

The problems were with the device string in the add device section of zonecfg:

1) A "/*" at the end of the device string (in effect pointing past where the zvol is); this seems to be what is causing the crash.

2) The string referenced the rdsk, not the dsk. I don't think this caused the crash problem, but the Oracle docs say that using rdsk is a bad idea.

I've sent a separate message to the OmniOS discuss list regarding the change to the Wiki.

Thanks Yuri.

Actions #5

Updated by Graham Stephens over 6 years ago

According to Dan at Omni (who looked at the crash dump for me), this is a repeat of bug 5421 which has been fixed in the latest release.

Thanks.

Actions #6

Updated by Marcel Telka over 6 years ago

  • Is duplicate of Bug #5421: devzvol_readdir() needs to be more careful with strchr added
Actions #7

Updated by Marcel Telka over 6 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF