Project

General

Profile

Bug #5978

5816 causes mdb's ::status message to be further truncated

Added by Robert Mustacchi almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Category:
mdb - modular debugger
Start date:
2015-06-03
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

5816 introduced a regression where the status is always truncated. Consider the following core:

{code}

::status

debugging core file of varpd (32-bit) from 00-0c-29-ca-c7-23
file: /usr/lib/varpd/varpd
initial argv: /usr/lib/varpd/varpd
threading model: native threads
status: process terminated by SIGABRT (Abort), pid=102079 uid=0 code=-1
panic message: ***

panicstr/K

libc.so.1`panicstr:
libc.so.1`panicstr: fdf19db0

fdf19db0/s

0xfdf19db0: *** libc mutex system failure: mutex_enter: bad mutex type {code}

Notice that we only see the first three characters of the panic string. This is because when 5816 changed panicbuf to be a dynamic allocation it did not update the call to Pread_string() which uses sizeof (panicbuf). Of course, that's now just 4, becuase panicbuf is no longer an array, but a pointer.

#1

Updated by Electric Monk over 5 years ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

git commit f68770eaa148461c70a7bafc74cf10adf8fb4add

commit  f68770eaa148461c70a7bafc74cf10adf8fb4add
Author: Robert Mustacchi <rm@joyent.com>
Date:   2015-06-09T14:47:43.000Z

    5978 5816 causes mdb's ::status message to be further truncated
    Reviewed by: Dan McDonald <danmcd@omniti.com>
    Reviewed by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Approved by: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>

Also available in: Atom PDF