Project

General

Profile

Actions

Bug #5983

closed

5896 fallout when EMI is removed

Added by Robert Mustacchi about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Category:
smf
Start date:
2015-06-05
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

We've seen regressions where we have a warning from svccfg when EMI has been removed from a repository when doing an import or archive. It unfortunately causes a warning to be emitted due to the use of smf_get_state failing. Instead, in such cases where we can't properly determine whether EMI exists or not, we opt to instead not enforce the check, which leaves things no worse off than before 5896. In the future, in theory svccfg could do a full check to see whether or not EMI has been deleted or not from the repository.

Actions #1

Updated by Electric Monk about 6 years ago

  • Status changed from Pending RTI to Closed
  • % Done changed from 90 to 100

git commit a6490d0f4f068b0e0b17b98d03e50301aa6bb3f4

commit  a6490d0f4f068b0e0b17b98d03e50301aa6bb3f4
Author: Robert Mustacchi <rm@joyent.com>
Date:   2015-06-09T21:53:54.000Z

    5983 5896 fallout when EMI is removed
    Reviewed by: Andy Stormont <astormont@racktopsystems.com>
    Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Actions

Also available in: Atom PDF