Project

General

Profile

Bug #6008

"you must be root to use savecore" message is not always true

Added by Rich Lowe about 5 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Start date:
2015-06-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

If you need more privileges than you have, savecore says "You must be root to use savecore". That's not quite true. You must be able pull the dump off of the dump device (maybe that really is a check for uid 0, I'm not sure), but uncompressing compressed dumps and such requires no special privilege.

The wording should probably be made more explicit.

I encountered this because I typoed a command line in such a way that -- for reasons unknown -- caused savecore to check for privs before checking for sanity. savecore should also, ideally, not do that. (I switched the directory and file arguments due to an editting mishap, thus 'savecore . -f foo').

Also available in: Atom PDF