Project

General

Profile

Feature #6035

Decommission GCC 4.7.4

Added by Ken Mays almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
OI-Userland
Target version:
-
Start date:
2015-06-25
Due date:
2015-09-01
% Done:

0%

Estimated time:
8.00 h
Difficulty:
Bite-size
Tags:
gcc

Description

Decommission GCC 4.7.4 due to increased FOSS developer testing and usage of GCC 4.8/4.9 series.
GCC 4.7.4 is no longer widely used nor tested at this time.

Aso, serious bugs were found during our early FOSS testing of GCC 4.7.4 which was decided as a "won't fix" by the GCC developers
in lieu of their push for GCC 4.8.x/4.9.x migration(s).

#1

Updated by Alexander Pyhalov almost 6 years ago

I think it's all right to deprecate GCC 4.7 only when GCC Next is available (4.9 or 5.1) so that we always have at least two compilers available.

#2

Updated by Ken Mays almost 6 years ago

Then, keep GCC 4.7.4 for now. Close this ticket.

#3

Updated by Alexander Pyhalov over 5 years ago

  • Status changed from New to Resolved

gcc-47 was removed.

Also available in: Atom PDF