Project

General

Profile

Actions

Bug #6063

closed

pkgadd breaks with too many mountpoints

Added by Simon K almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
2015-07-16
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

Iā€™m unable to install packages on a machine with more than 32768 mountpoints. The output of pkgadd stops after ā€œ## Checking for conflicts with packages already installed.ā€ and I get a coredump with the following stack:

> pstack /var/tmp/core.pkginstall.26427
core '/var/tmp/core.pkginstall.26427' of 26427: /usr/sadm/install/bin/pkginstall -O pkg-server-mode=timeout26417 -v -d
 08066e4d use_srvr_map_n (8045cac, 85aa5d8, 8045cb8, feebe1a0) + d
 0805b4b8 dockspace (0, 0, 8076080, 8095180, 7261762f, 706d742f) + 18
 0805a0fe ckspace  (1, 0, 8047988, 8060b53, 805a047, 5) + b7
 0805da37 ck_w_dryrun (805a047, 5) + a
 08060b53 main     (804797c, fef74688, 80479b4, 8058a07, 10, 80479c0) + 20ae
 08058a07 _start   (10, 8047b14, 8047b35, 8047b38, 8047b55, 8047b58) + 83

I guess the problem is that get_fs_entry() (called by dockspace()) is dealing with a short variable instead of long or at least int.

Actions #1

Updated by Electric Monk almost 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit e47aa97b65b6eaa7016357de7fb7974c1982858c

commit  e47aa97b65b6eaa7016357de7fb7974c1982858c
Author: Simon Klinkert <simon.klinkert@gmail.com>
Date:   2015-07-19T19:11:11.000Z

    6063 pkgadd breaks with too many mountpoints
    Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@omniti.com>

Actions

Also available in: Atom PDF