Project

General

Profile

Actions

Bug #6184

closed

Circular library dependency

Added by Alexander Kolbasov over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
2015-08-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I noticed a circular dependency that prevents building illumos libraries using just libs in the photo area.

Here is the dependency:

libdladm -> libsec -> libidmap -> libldap5 -> libsasl -> pkcs11 -> libuuid -> libdladm

As a result, building pkcs11 uses /lib/libdladm rather than the one in proto.


Related issues

Is duplicate of illumos gate - Feature #6114: factor out dladm walking into its own libraryClosedRobert Mustacchi2015-08-11

Actions
Actions #1

Updated by Yuri Pankov over 5 years ago

  • Is duplicate of Feature #6114: factor out dladm walking into its own library added
Actions #2

Updated by Yuri Pankov over 5 years ago

Should be closed as a #6114 duplicate.

Actions #3

Updated by Yuri Pankov over 5 years ago

  • Status changed from New to Closed

Should be fixed in #5468.

Actions

Also available in: Atom PDF