Project

General

Profile

Bug #619

Cannot connect into Root, password acces denied

Added by Olivier Pinard almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Category:
Caiman (Installer)
Target version:
-
Start date:
2011-01-11
Due date:
% Done:

50%

Estimated time:
Difficulty:
Tags:

Description

Hi, i see on the real opensolaris web site that is attemp some more of 1000 people. After my installation, i reboot and i connect to my account with the same password from the installation. After, i want to connect my laptop to my wireless connection but its asking my the root, i enter the same password from the login screen but don't work at all. Testing other like : User : root ; Password : opensolaris or jack jack... don't work at all.

After reboot on one of my ubuntu (yes i use some multiboot like 3 ubuntu, w7, Hackintosh iatkos s3v2 and Opensuse) I found on the wiki of opensolaris some user mod command. I reboot on opensolaris, open session, open terminal and does the following command :

#usermod -R root username

I work and its ask for reboot or log out, i log out. Reopen the session and don't work (damn!).

I use the b plan :

#rolemod -K type=normal root

Acces denied, you don't have the permission...

I cannot say exactly the same word of the terminal because internet don't work and i cannot acces zfs partition on ubuntu maverick and mount other file system on openindiana because it don't found one...

#1

Updated by Olivier Pinard almost 10 years ago

I test with an another password on installation and it don't work more than before... I thinked it is because I use a soustraction symbol in math (-) but it's not that...

I have download the DVD version if it could help you.

#2

Updated by Matt Wilby almost 10 years ago

  • Assignee set to Matt Wilby
  • Priority changed from Normal to Low

Is this still an issue?

Just to rule it out, have you tried booting from the livecd, mounting your install and resetting your root password?

Thanks.

#3

Updated by Olivier Pinard almost 10 years ago

Ok, I will test and I will bring the result.

#4

Updated by Olivier Pinard almost 10 years ago

  • % Done changed from 0 to 50

Yata !!! (Japanese traduction : I did it !!!)

First I cannot mount my partition on live dvd. I boot the last installation on hdd. And i loggin my session. Open terminal, does

  1. sudo -s

root# passwd

I type the new password for fgt1 (me)

root# passwd root

Type the new password for the root.

Test it and work !!!

Now I have root permission.


Finally, I think it is a problem on the installation program for cryption on /ect/shadow

I think than the bug be at 50 % :D
My problem was result but not for other !!!

#5

Updated by Matt Wilby almost 10 years ago

  • Category changed from Security to Caiman (Installer)
  • Status changed from New to In Progress
  • Assignee changed from Matt Wilby to Guido Berhörster
  • Priority changed from Low to Normal

Thanks for the update. I've repeated the issue. Seems to be installer related.

'sudo passwd root' to change root's passwd.

Possible dupe of issue #204 as had to do 'usermod -P "Primary Administrator" username' before pfexec would work as normal user.

#6

Updated by Matt Wilby almost 10 years ago

  • Assignee changed from Guido Berhörster to Alasdair Lumsden
#7

Updated by Matt Wilby almost 10 years ago

  • Status changed from In Progress to Closed

Duplicate. New bug #636 created to cover all instances (#204, #579, #619) .

Also available in: Atom PDF