Project

General

Profile

Bug #6219

esc is sensitive to /usr/bin/cpp

Added by Josef Sipek about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Start date:
2015-09-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

During nightly build, esc is built and invoked. The invocation uses the preprocessor installed on the system. First, it tries /usr/bin/cpp. If that doesn't exist, it tries /usr/lib/cpp. It is entirely reasonable for a distro to put something in /usr/bin/cpp that's not compatible with what esc expects (e.g., gcc's cpp). (Note, illumos-gate ships nothing to either location. /usr/lib/cpp is delivered by pkg:/developer/macro/cpp on OI.)

The quick fix may be as easy as changing esc to only use /usr/lib/cpp.


Related issues

Is duplicate of illumos gate - Bug #11617: esc fails with /usr/bin/cpp presentClosedRobert Mustacchi

Actions
#1

Updated by Jim Klimov almost 4 years ago

Note: Looking at code (because I did have a problem with `esc` taking a wrong `cpp`) I found there is support for an `_ESC_CPP` envvar to use whatever the caller wants. Otherwise it indeed uses `/usr/bin/cpp` by default. In both cases it falls back to `/usr/lib/cpp` if the first requested path to binary is absent.

Some other code in the gate also refers to `/usr/libexec/cpp` but nothing installs that. I am not sure at this time if this assumes the same functionality as (Sun Studio?) `/usr/lib/cpp` or some third interpreter.

#2

Updated by Yuri Pankov about 1 year ago

  • Is duplicate of Bug #11617: esc fails with /usr/bin/cpp present added
#3

Updated by Yuri Pankov about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF