Project

General

Profile

Bug #6269

mismatch between manpage /etc/timezone and actual file (symlink) /etc/TIMEZONE

Added by Richard PALO about 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2015-09-30
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

I believe this says it all.

richard@omnis:/home/richard/src/illumos-gate$ git grep -i "etc\/timezone" 
usr/src/man/man4/init.4:\fB/etc/TIMEZONE\fR is a symbolic link to \fB/etc/default/init\fR.  This
usr/src/man/man4/timezone.4:\fB/etc/timezone\fR
usr/src/man/man4/timezone.4:Here is a typical line from the \fB/etc/timezone\fR file:
usr/src/man/man4/timezone.4:\fB\fB/etc/timezone\fR\fR
usr/src/pkg/manifests/SUNWcs.mf:link path=etc/TIMEZONE target=./default/init

History

#1

Updated by Garrett D'Amore about 4 years ago

Richard PALO wrote:

I believe this says it all.
[...]

Uh... no. Look carefully. /etc/TIMEZONE (all caps) is indeed a a historical link to /etc/default/init (we really should remove that link, nothing should be using it anymore!)

The /etc/timezone (lower case) file is used only in building NIS maps.

Sadly man(1) doesn't deal with the difference in cases here well at all, and if you are on a case insensitive filesystem (or your tree is, like MacOS HFS) then you can't see the difference.

No bug here, unless its that /etc/TIMEZONE still exists at all.

#2

Updated by Richard PALO about 4 years ago

But /etc/timezone doesn't exist either (at least not on OmniOS nor OI)

#3

Updated by Peter Tribble about 4 years ago

It probably wouldn't be a bad thing to remove timezone(4) and the timezone stuff from /var/yp/Makefile.

It's only relevant to jumpstart installs, and even if illumos is being used as a NIS server in a jumpstart environment, guessing things from NIS was replaced by sysidcfg files a long time ago.

#4

Updated by Yuri Pankov over 3 years ago

  • Status changed from New to Rejected

Not a bug.

Also available in: Atom PDF