Project

General

Profile

Bug #6319

assertion failed in zio_ddt_write: bp->blk_birth == txg

Added by Matthew Ahrens about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2015-10-10
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The problem is that the fix for:

5693 ztest fails in dbuf_verify: buf[i] == 0, due to dedup and bp_override

Was incorrect, and needs to be reverted.

History

#1

Updated by Electric Monk about 4 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit b39b744be78c6327db43c1f69d11c2f5909f73cb

commit  b39b744be78c6327db43c1f69d11c2f5909f73cb
Author: Matthew Ahrens <mahrens@delphix.com>
Date:   2015-10-22T23:14:49.000Z

    6319 assertion failed in zio_ddt_write: bp->blk_birth == txg
    Reviewed by: George Wilson <george.wilson@delphix.com>
    Approved by: Dan McDonald <danmcd@omniti.com>

Also available in: Atom PDF