Project

General

Profile

Bug #6354

dtrace -c doesn't properly handle arguments that contain spaces

Added by Paul Dagnelie almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2015-10-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

a command like

dtrace -n 'fbt::read:entry {}' -c 'cat file\ name.txt'

does not work correctly, because dtrace will attempt to cat 'file\' and "name.txt". This stems from https://github.com/illumos/illumos-gate/blob/master/usr/src/cmd/dtrace/dtrace.c#L276, which blindly splits tokens by whitespace, without attempting to detect escape characters or quotes.


Related issues

Is duplicate of illumos gate - Bug #1440: dtrace -c doesn't parse the command string properlyNew2011-09-01

Actions

History

#1

Updated by Ryan Zezeski almost 2 years ago

  • Is duplicate of Bug #1440: dtrace -c doesn't parse the command string properly added
#2

Updated by Andy Fiddaman about 1 year ago

  • Status changed from New to Closed

Closing duplicate

Also available in: Atom PDF