Project

General

Profile

Bug #6412

zfs receive: -u can be ignored sometimes

Added by Andriy Gapon almost 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
zfs - Zettabyte File System
Start date:
2015-10-30
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

It seems that zfs receive -F -u would mount a received filesystem after receiving a full stream if a destination filesystem already existed (and, thus, got destroyed and re-created) and was mounted.

How to reproduce:

$ zfs create rpool/sandbox
$ zfs create rpool/sandbox/from
$ zfs create rpool/sandbox/to
$ zfs snap rpool/sandbox/from@snap
$ zfs send rpool/sandbox/from@snap | zfs recv -v -F -u rpool/sandbox/to
receiving full stream of rpool/sandbox/from@snap into rpool/sandbox/to@snap
received 41.7KB stream in 1 seconds (41.7KB/sec)
$ zfs get mounted rpool/sandbox/to
NAME                  PROPERTY  VALUE    SOURCE
rpool/tmp/sandbox/to  mounted   yes      -

This behavior can be problematic if the mountpoint property changes either because it had a non-inherited value or the stream contains properties because it has been generated with either -R or -p.

History

#1

Updated by Electric Monk almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 9185393f2919d8b897f6142d8a9fa0429c285dc1

commit  9185393f2919d8b897f6142d8a9fa0429c285dc1
Author: Andriy Gapon <andriy.gapon@clusterhq.com>
Date:   2016-11-14T19:24:01.000Z

    6412 zfs receive: -u can be ignored sometimes
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Reviewed by: Paul Dagnelie <pcd@delphix.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF