Project

General

Profile

Actions

Bug #6453

closed

get_tz_countries needs to cope with UTF-8 country.tab files

Added by Dan McDonald almost 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
lib - userland libraries
Start date:
2015-11-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Hard
Tags:
needs-triage
Gerrit CR:
External Bug:

Description

Starting somewhere between 2015a and 2015g, the country.tab file became UTF-8 happy.

This needs to be changed in libzoneinfo AND its consumers. This bug covers the libzoneinfo portion. The consumers are more of a distro problem. The caiman installer used by OmniOS and OI, for example, will need to be updated as well.

Actions #1

Updated by Yuri Pankov almost 7 years ago

While here, do we need the libzoneinfo at all? Getting rid of it would allow us to ship zone.tab unmodified.

Actions #2

Updated by Dan McDonald almost 7 years ago

Yuri Pankov wrote:

While here, do we need the libzoneinfo at all? Getting rid of it would allow us to ship zone.tab unmodified.

Good question, perhaps we should ask the list? Also, there are consumers that need to be accounted for.

Actions #3

Updated by Dan McDonald almost 7 years ago

  • Status changed from New to Rejected

Not a bug. Turns out this is an issue in specific installers, and not in illumos-gate. There's a larger question of libzoneinfo in general being useful, but that should be a separate issue.

Actions

Also available in: Atom PDF