Project

General

Profile

Actions

Bug #6482

closed

[PATCH] GRUB won't boot when built with GCC 5

Added by Andrew Stormont over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
2015-11-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

I'm not sure why this works, but it does. The fix was posted to the Debian mailing list.


Files

grub-gcc5.diff (986 Bytes) grub-gcc5.diff Andrew Stormont, 2015-11-26 02:14 PM

Related issues

Has duplicate illumos gate - Bug #9754: grub: recent gcc needs -fno-reorder-functionsClosedToomas Soome2018-08-17

Actions
Actions #1

Updated by Andrew Stormont over 6 years ago

Explanation of the problem caused by a new GCC optimisation feature.
https://lists.ubuntu.com/archives/ubuntu-devel/2011-September/034127.html

Actions #2

Updated by Igor Kozhukhov over 6 years ago

they are flags not enough for grub build and work by gcc version more 4.4.
i have some additional patches on my dilos-illumos tree for builds and work by gcc47/48/49
also, some flags can break gcc44.

Actions #3

Updated by Andrew Stormont over 6 years ago

You're right more changes are required. I want to tackle them one at a time.

This change shouldn't break anything since GCC 4.4.4 also supports the -fno-reorder-functions flag but I haven't tested that out.

Actions #4

Updated by Kim Shrier over 6 years ago

This appears to fix a problem that everybody ran into when compiling with GCC >= 4.6.

LGTM

Actions #5

Updated by Andrew Stormont over 3 years ago

  • Has duplicate Bug #9754: grub: recent gcc needs -fno-reorder-functions added
Actions #6

Updated by Andrew Stormont over 3 years ago

  • Status changed from Feedback to Closed

This is fixed as of #9754.

Actions

Also available in: Atom PDF