Project

General

Profile

Bug #6484

[PATCH] GRUB should specify c89 for GCC 5

Added by Andrew Stormont almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
2015-11-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

GCC 5 changed the default standards mode to gnu11 and this causes problems.


Files

grub-c99.diff (860 Bytes) grub-c99.diff Andrew Stormont, 2015-11-26 03:10 PM

Related issues

Is duplicate of illumos gate - Bug #6648: illumos build should be explicit about C standardsClosed2016-02-12

Actions

History

#1

Updated by Andrew Stormont almost 4 years ago

  • Subject changed from [PATCH] GRUB should specify c99 for GCC 5 to [PATCH] GRUB should specify c89 for GCC 5
#2

Updated by Andrew Stormont over 3 years ago

  • Is duplicate of Bug #6648: illumos build should be explicit about C standards added
#3

Updated by Andrew Stormont over 3 years ago

  • Status changed from Feedback to Closed

Closing as a duplicate. A fix was included as part of the changes for #6648.

Also available in: Atom PDF