Project

General

Profile

Actions

Bug #6504

closed

twm/xorg - doesn't boot with startx at console

Added by James Deagle almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-12-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

This is my first time reporting an OI bug, and after six months of continuous usage I still consider myself a SunOS 5.11 newb, albet a proud one. I don't know if the issue below is a genuine bug or just a glitch with my chair-keyboard interface, but here it goes...

I've been trying to start xorg and twm from the console with startx, but I get the following (which was documented using the script command):

Script started on 9 December, 2015 04:44:54 AM EST
jed@darkstar:~$ startx
xauth: file /home/jed/.serverauth.1703 does not exist

(EE)
Fatal server error:
(EE) Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"
(EE)
(EE)
Please consult the Project OpenIndiana support
at http://openindiana.org
for help.
(EE)

^Z
[1]+ Stopped startx
jed@darkstar:~$ exit
exit
There are stopped jobs.
jed@darkstar:~$ exit

For what it's worth, my .xinitrc file looks like this:

xsetroot -solid grey &
twm

I have also rendered the twm line as /usr/bin/twm, but with the same output as above. Also, as this installation is very new, the shell is still set to the bash default, just in case there is a possibility (however remote) that the issue is bash-related.

Thank you for your time and attention, and for all of your work on this awesome OS!

Cheers,
James

Actions #1

Updated by Josef Sipek almost 6 years ago

  • Project changed from illumos gate to OpenIndiana Distribution

(This seems like an OI bug - not an illumos-gate bug. I moved it over to OI.)

Is this on Hipster or OI /dev?

Actions #2

Updated by James Deagle almost 6 years ago

Thanks for the assist.

The installation is OI Hipster, from the October 2015 iso, with "pkg image-update -v" done two days ago.

Cheer,
James

Actions #3

Updated by Alexander Pyhalov almost 6 years ago

Should be solved by https://github.com/OpenIndiana/oi-userland/commit/94e5e5c8711c8e453f018ce3475e788d19bb33cb . Will appear in package repository in several hours.

Actions #4

Updated by Alexander Pyhalov almost 6 years ago

  • Status changed from New to Feedback
Actions #5

Updated by Alexander Pyhalov almost 6 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF