Project

General

Profile

Bug #6526

Bug #6486: Cannot install GCC 3 and others

Cannot install GCC 3 and others (take two)

Added by mYse|f 600 about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
PKG (Image Packaging System)
Target version:
Start date:
2015-12-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

This is a follow-up to my previous bug report #6486 which hasn't been resolved due to my absence. Because of that, I'm creating a new bug report.

Yesterday, I tried to make a clean installation of OpenIndiana Hipster using the latest 2015.10 and older 2015.03 GUI ISO images under VirtualBox OSE 5.0.6 to rule out the possibility that the issue can be fixed by this. This haven't made any difference and since building GCC under Solaris seems to be a difficult task in itself, this isn't an option for me. As I mentioned earlier, I need gcc-3 to build the Solaris Guest Additions package for VirtualBox, and I would also like to try the newer gcc-43 (available from the "legacy" repository) as this documentation suggest using it. The last time I successfully managed to install SUNWgcc under Hipster 2015.10.03 was on October 10.

Screenshot showcasing the issue


Files

gcc_issue.png (52.6 KB) gcc_issue.png Screenshot showcasing the issue mYse|f 600, 2015-12-19 01:56 PM
#1

Updated by Aurélien Larcher about 5 years ago

Hello,
I do not understand why you are still trying to use legacy package names like SUNWgcc that are now deprecated.
Can't you just pkg install developer/gcc-3 ?


alarcher@helios> pkg info -r SUNWgcc
           Nom: SUNWgcc
         State: Non installé (Renommé)
    Renamed to: developer/gcc-3@3.4.3-0.133
       Editeur: openindiana.org
       Version: 3.4.3
        Branch: 0.133
Packaging Date: 13 novembre 2015 16:39:14
        Taille: 0.00 o
          FMRI: pkg://openindiana.org/SUNWgcc@3.4.3-0.133:20151113T163914Z
alarcher@helios> pkg info -r developer/gcc-3@3.4.3-0.133
pkg: info: no packages matching the following patterns you specified were
found in the catalog.  Try relaxing the patterns, refreshing, and/or
examining the catalogs:

        developer/gcc-3@3.4.3-0.133

So it seems the renamed package does not exist in the repo, your error makes sense.

#2

Updated by Aurélien Larcher about 5 years ago

Moreover the documentation that your are pointing to concerns cross-compilation on a Linux host.

These are my notes from setting up a cross-compiler for building the Solaris Additions on a Linux host.
I used version 2.19 of the binutils package and 4.3.6 of gcc (unmodified 3.4.3 couldn't build 64 bit object 
files for Solaris and 4.4 and later aren't compatible with the Solaris 11 header files)

Are you sure gcc-49 cannot be used ?

#3

Updated by mYse|f 600 about 5 years ago

Hi!

Because this is the first time I had to use a Solaris based distribution, so I haven't knew about this before the issue happened. As far as I can see, SUNWgcc is just a metapackage targeting gcc-3 which cannot be installed. I used to install SUNWgcc before, that's why I mentioned it specifically instead of gcc-3 in this bug report.

The SolarisCrossCompiler documentation suggest using GCC 4.3.6, that's what I was trying to emphasize.

Regarding the VirtualBox Solaris Additions, I have tried to build it also using gcc-47 and gcc-48 (the only versions pkg currently allows to install), however, in both cases the compilation terminated with an error when I tried to compile it for 32 bit (the 64 bit build succeeded). Since I currently doesn't have the ability to install other GCC versions, I might be unable to debug this issue.

#4

Updated by Aurélien Larcher about 5 years ago

Hello,
it is the specific version '' that cannot be installed, but the package itself can be.
'pkg install gcc-3' just works fine on fresh hipster 2015 installations.

Maybe the documentation could be updated to reflect the deprecation of SUNWgcc as package name on OI.

#5

Updated by Alexander Pyhalov about 5 years ago

If entire still holds any incorporate dependencies, update your system first.

#6

Updated by Alexander Pyhalov about 5 years ago

  • Status changed from New to Rejected

Not a bug, system should be updated to use new packages.

Also available in: Atom PDF