Project

General

Profile

Feature #6536

zfs send: want a way to disable setting of DRR_FLAG_FREERECORDS

Added by Andrew Stormont over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
2015-10-26
Due date:
2015-10-26
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

We recently ran into an issue where we were unable to zfs recv from systems with the fix for 6393 (zfs receive a full send as a clone) which introduced a new DRR flag (DRR_FLAG_FREERECORDS). It turns out we added a flag with the same value and now we have a conflict. We will change our value to something else, in the meantime we need a way to generate streams that don't include DRR_FLAG_FREERECORDS.

It seems that it might also be desireable to have support for generating streams without free records for other reasons, such as in cases where we definitely know that the receiving end is not receiving the stream as a clone. An example of this might be when using some kind of automatic replication process. I propose that we add a new option to zfs send (-F) that turns off sending of free records.


Related issues

Follows illumos gate - Bug #6393: zfs receive a full send as a cloneClosed2015-10-24

Actions

History

#1

Updated by Andrew Stormont over 3 years ago

  • Subject changed from zfs send: want a way to disable sending of free reconds to zfs send: want a way to disable sending of free records
#2

Updated by Andrew Stormont over 3 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Assignee set to Andrew Stormont
#3

Updated by Andrew Stormont over 3 years ago

#4

Updated by Andrew Stormont over 3 years ago

  • Description updated (diff)
#5

Updated by Andrew Stormont over 3 years ago

  • Due date set to 2015-10-26
  • Start date changed from 2015-12-30 to 2015-10-26
  • Follows Bug #6393: zfs receive a full send as a clone added
#6

Updated by Andrew Stormont over 3 years ago

  • Description updated (diff)
#7

Updated by Andrew Stormont over 3 years ago

  • Subject changed from zfs send: want a way to disable sending of free records to zfs send: want a way to disable setting of DRR_FLAG_FREERECORDS
#8

Updated by Electric Monk over 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 880094b6062aebeec8eda6a8651757611c83b13e

commit  880094b6062aebeec8eda6a8651757611c83b13e
Author: Andrew Stormont <astormont@racktopsystems.com>
Date:   2016-02-02T21:53:09.000Z

    6536 zfs send: want a way to disable setting of DRR_FLAG_FREERECORDS
    Reviewed by: Anil Vijarnia <avijarnia@racktopsystems.com>
    Reviewed by: Kim Shrier <kshrier@racktopsystems.com>
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Approved by: Dan McDonald <danmcd@omniti.com>

#9

Updated by O F about 2 years ago

Hi,

as it turns out this problem is not fixed yet according to the following archived mailinglist:

https://www.mail-archive.com/discuss@lists.illumos.org/msg02734.html

The problem is I can't upgrade the receiver side. Is this something that can and will be fixed on the sender side?

Also available in: Atom PDF