Project

General

Profile

Actions

Feature #6602

closed

lofi should support labeled devices

Added by Toomas Soome over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2016-02-03
Due date:
% Done:

100%

Estimated time:
Difficulty:
Hard
Tags:
needs-triage
Gerrit CR:

Description

mostly motivated to support building usb images (including boot loader install), would like to have lofi to support labeled devices.

from user perspective it adds companion switch to lofiadm [-l] -a, and label is only applicable for uncompressed/unencrypted cases. labeled device is reported as:
root@sparc5:/# lofiadm -la test
/dev/dsk/c6t1d0p0

and from format:
6. c6t1d0 <lofi-test-1.0 cyl 510 alt 2 hd 128 sec 32>
/pseudo/lofi@1
Specify disk (enter its number):

resulting device can be used to create partition(s) (EFI/SMI, MBR is essentially x86 only), file systems created, boot programs installed. Labeled lofi is also usable in local zones, with usual notes about potential danger of triggering kernel panic by corrupting file systems...


Related issues

Related to illumos gate - Bug #7941: cannot use crypto lofi on a block/character deviceClosedToomas Soome2017-03-06

Actions
Related to illumos gate - Bug #10262: excessive page destruction caused by 6602ClosedPatrick Mooney2019-01-18

Actions
Actions #1

Updated by Electric Monk almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

git commit 406fc5100dac8d225a315a6def6be8d628f34e24

commit  406fc5100dac8d225a315a6def6be8d628f34e24
Author: Toomas Soome <tsoome@me.com>
Date:   2016-06-21T14:56:21.000Z

    6602 lofi should support labeled devices
    Reviewed by: Igor Kozhukhov <ikozhukhov@gmail.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Reviewed by: Garrett D'Amore <garrett@damore.org>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Approved by: Dan McDonald <danmcd@omniti.com>

Actions #2

Updated by Josef Sipek about 4 years ago

  • Related to Bug #7941: cannot use crypto lofi on a block/character device added
Actions #3

Updated by Dan McDonald over 2 years ago

  • Related to Bug #10262: excessive page destruction caused by 6602 added
Actions

Also available in: Atom PDF