Project

General

Profile

Bug #662

GRUB hangs with Error 17: Unable to mount selected partition

Added by Nick Zivkovic almost 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-01-24
Due date:
% Done:

50%

Estimated time:
Difficulty:
Tags:

Description

So, after creating1 2 different LiveUSB's (OI_147, OI_148), I try to boot with either one, and after selecting the first entry in GRUB's boot menu, I get dropped to a screen that indicates that GRUB couldn't mount 'selected partition'.

This bug is gigantic exclamation point. It's one thing if Illumos/Openindiana have bugs during runtime, which can be worked around and fixed. It's quite another if they can't even boot into the live distribution for a simple installation procedure.

I will try to reproduce this problem with Windows usb install app, once I get access to a Windows machine. I'll update this with the results of that.

[1] Both usb's were created on an openindiana-148 system, which was obtained via pkg image-update from opensolaris-134. I used the usbcopy found in the distribution-constructor package.

Thanks,
-Nick

History

#1

Updated by Nick Zivkovic almost 9 years ago

  • % Done changed from 0 to 50

Apparently, after much reading and research, it seems that GRUB does things within the constraints of the BIOS settings. Indeed, I was able to get the usb to boot, by tweaking BIOS. (the usb was telling bios to boot off my disk which didn't have anything on it).

I marked this bug as 50% done, because ideally, the openindiana installer/liveusb would be able to circumvent this limitation. Not sure if it's feasible for liveusb's, but a bunch of livecd's seem to have this functionality figured out (as far as I can tell).

Thanks

#2

Updated by Albert Lee almost 9 years ago

  • Status changed from New to Rejected

What you suggest is not technically feasible.

Also available in: Atom PDF