Project

General

Profile

Bug #6656

ixgbe fails to power on PHY and SFP tx laser

Added by Dale Ghent almost 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
networking
Start date:
2016-02-15
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

ixgbe(7D)'s attach and initialization routine expects the PHY and SFP Tx optics (if present) to be powered on. I ran into an interesting case where, after rebooting from a Linux image into OmniOS with an in-development ixgbe for X550, my X550 failed to negotiate any link, and I could not force it to. Only after a system power cycle (power off & power on) would I resume getting a link.

It turns out that, as a part of Linux's ixgbe driver stop routine, it powers down the PHY and switches off any SFP Tx laser. The PHY will stay in this powered-off state until it is told to turn back on, which is not caused by a system reset or controller reset - one has to explicitly turn the hardware back on. If you do not do that, one will need to power-cycle the system to force the PHY back into its default-on state.

FreeBSD recently fixed this issue: https://github.com/freebsd/freebsd/commit/8887150af48686df7b5c2f7317a20a9d5320ab5f#diff-b0214db036b5b1c842cb85157352fdee


Related issues

Related to illumos gate - Feature #6064: ixgbe needs X550 supportClosed2016-06-07

Actions

History

#1

Updated by Robert Mustacchi over 1 year ago

It looks like this was taken care of with the work in 6064.

#2

Updated by Robert Mustacchi over 1 year ago

#3

Updated by Robert Mustacchi over 1 year ago

  • Status changed from New to Resolved
#4

Updated by Robert Mustacchi over 1 year ago

  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Also available in: Atom PDF