Project

General

Profile

Bug #6678

Screensaver locks up

Added by James Deagle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
XNV (X Window System)
Target version:
Start date:
2016-02-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi all,

I have installed OI Hipster from the October 2015 iso, and have it patched up to the latest as of February 25.

My issue is that after the screensaver comes on (and by "screensaver" I merely mean the screen going black), there doesn't appear to be any way to unlock it, thus neccessitating a hard reboot or shut down.

As a possible clue, I'm wondering if this may have the same root case as bug # 6677 ("Can't exit gdm to console mode")? (They both involve being trapped in black screens with no escape other than hard reboots.)

Cheers,
James

History

#1

Updated by Nikola M. over 3 years ago

Hello, I can't replicate described screensaver locking, I am on VESA, using i945 graphics.
I can unlock it when it locks.
What graphics/driver do you use?

Probably doesn't have connection with you previous report, because you have to have VT consoles enabled for console to work when gdm is disabled. (http://wiki.openindiana.org/oi/4.8+Virtual+Terminals+%28Virtual+Consoles%29)

#2

Updated by Nikola M. over 3 years ago

Hi, can you please respond if you still see the issue. it is important to know what hardware you use.
How it behaves with latest hipster?. (hipster moved to /hipster path in meantime):
http://wiki.openindiana.org/oi/2016.04+Release+notes
See if you can reproduce after update so we can resolve your report. Thanks.

#3

Updated by James Deagle over 3 years ago

Hi,

My problem in general with OI-Hipster these days goes well beyond my two most recent bug reports, as it has been becoming less and less functional every time I install it. I downloaded the most recent live iso image, and lo and behold the boot process freezes at: "Loading stage2...". If I can't even boot the live image, then I don't know what else to do to further the progress on resolving this bug or the other one.

Cheers,
James

#4

Updated by Aurélien Larcher over 3 years ago

This does not look like an Hipster issue per se but a broken GRUB installation on your disk.

#5

Updated by Nikola M. over 3 years ago

Hi, can you please describe what hardware do you use and try to install?
Try reinstalling GRUB from Live media if that is the problem:
http://wiki.openindiana.org/oi/How+to+migrate+the+root+pool
(pfexec installgrub /boot/grub/stage1 /boot/grub/stage2 /dev/rdsk/c6t0d0s0 or such)

There is also newer loader project in the working, that takes EFI into account and will probably replace GRUB in the future.http://www.openindiana.org/2016/05/09/boot-loader-project-demo-v6/
so you can join testing it, too.
Latest (OI hipster) ISO and USB image are 20160421, but you can also try installing from 20151010 or even 201503, where you will get hipster-2015 and then you can update to latest /hipster to check if there is still any issue.

If still havig problem installing on your hardware please rpeort it but please respond to see if it is solved with GRUB reinstall or something else.

#6

Updated by Aurélien Larcher over 3 years ago

  • Category set to XNV (X Window System)
  • Assignee set to OI XNV
  • Target version set to Hipster
#7

Updated by Nikola M. over 3 years ago

Please report if not able to reproduce anymore. (updated /hipster)

#8

Updated by Nikola M. over 3 years ago

Suggest to be resolved as invalid , targeting older hipster-2015 and not able to reproduce.

#9

Updated by James Deagle over 3 years ago

Just today I reinstalled Hipster (October 2015 iso) and was able to patch it up to the latest revision (as of June 22, 2016), and found that this issue was resolved. :)

Ergo, this is no longer an issue..

#10

Updated by Aurélien Larcher over 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF