Project

General

Profile

Bug #673

sed -i argument temp file should be optional

Added by Andrew Stormont almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-01-27
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:
Gerrit CR:

Description

This is valid with gnu sed:

sed -i s/oldtext/newtext/g /my/sed/file

But for the illumos implementation this must be changed too:

sed -i '' s/oldtext/newtext/g /my/sed/file

because -i expects either '' or that path to a backup file.


Related issues

Is duplicate of illumos gate - Bug #586: sed -i should take an "optional" argumentResolvedYuri Pankov2010-12-29

Actions
#1

Updated by Garrett D'Amore almost 10 years ago

  • Status changed from New to Closed

This is a duplicate of 586.

Also available in: Atom PDF