Project

General

Profile

Actions

Bug #678

closed

ntxn could blow pointer in mac_alloc()

Added by Richard Elling over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-01-29
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:
Gerrit CR:

Description

By inspection,

http://src.illumos.org/source/xref/illumos-opengrok/usr/src/uts/common/io/mac/mac_provider.c#88

the return value of kmem_zalloc() is not checked before using it as a pointer for assignment. The return value could be NULL, causing a blown pointer.

Actions #1

Updated by Yuri Pankov over 10 years ago

Quoting kmem_alloc(9F):

KM_SLEEP allocations may sleep but are guaranteed to succeed.

So it's likely shouldn't be a problem?

Actions #2

Updated by Garrett D'Amore over 10 years ago

  • Status changed from New to Rejected

Correct. By definition KM_SLEEP allocations never fail. (They may take forever to satisfy though.)

This is not a bug. Closing.

Actions

Also available in: Atom PDF