Project

General

Profile

Bug #6815

encumbered/vlc fails to build

Added by Andreas Wacknitz over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
-
Start date:
2016-03-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

encumbered/vlc-2.2.1 fails to compile:

/oibuild/oibuild_projects/oi-userland-work/components/encumbered/vlc/vlc-2.2.1/modules/codec/png.c:201:16: warning: variable ‘p_row_pointers’ might be clobbered by ‘longjmp’ or ‘vfork’ [-Wclobbered]
png_bytep *p_row_pointers = NULL;
^
cc1: some warnings being treated as errors

History

#1

Updated by Alexander Pyhalov over 3 years ago

Can't reproduce. Builds fine here...

#2

Updated by Alexander Pyhalov over 3 years ago

  • Assignee set to Alexander Pyhalov
#3

Updated by Aurélien Larcher over 3 years ago

My guess is that you have extra flags in you env.
I have built VLC on 4 systems including a Virtualbox install.
You should try with current VLC 2.2.2 in oi-userland and if you cannot reproduce we close the issue.

#4

Updated by Andreas Wacknitz over 3 years ago

Ok, I guess I found my problem.
I had SunStudio-12.1 installed (by build-essential).
After installing SolarisStudio-12.3 the build went fine.
So, the ticket can be closed.

Regards
Andreas

#5

Updated by Alexander Pyhalov over 3 years ago

  • Status changed from New to Rejected

Don't know how it is related to studio, but closing as I can't reproduce it.

Also available in: Atom PDF