Feature #695

Prompt user to enter a root password.

Added by Leifur Hauksson about 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:2011-02-05
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Caiman (Installer)
Target version:-
Difficulty:Medium Tags:needs-triage

Description

Rather than automatically setting the root password to be the same as the user password, the user should be prompted during install to choose a root password.

History

Updated by Leifur Hauksson about 3 years ago

This should be a bug report, actually: the root password is expired on the first boot. To reproduce, after a standard installation, open a terminal and type 'su'. Then su will print "Password for user 'root' has expired".

It would be better to just have the user set a root password during installation, that way tasks that require root authentication may be done right away. Note that if you try to start a graphical program that requires root authentication while the root password is still expired, it doesn't explain that a new password is needed, just that authentication failed. For example, trying to configure the network with nwam-manager-properties by clicking on the icon in the system tray while the root password is expired.

Updated by Chris Jordan almost 3 years ago

  • Status changed from New to Closed
  • Difficulty set to Medium
  • Tags set to needs-triage

I'm closing this issue since it is a duplicate of bug #636.

Also available in: Atom PDF