Project

General

Profile

Bug #706

beadm should accept 'umount' as well as 'unmount'

Added by Rich Lowe almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
cmd - userland programs
Start date:
2011-02-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Tags:

Description

While it's yet another amongst the school of irritating unix misspellings, it's wired into everyone's fingers at this point that "unmount" is spelled "umount":
beadm should supply an alias.

The python implementation of beadm had this alias, so its absence represents a regression.

History

#1

Updated by Alexander Stetsenko almost 9 years ago

  • Assignee set to Alexander Stetsenko
#2

Updated by Alexander Stetsenko almost 9 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90
#3

Updated by Alexander Stetsenko over 8 years ago

  • % Done changed from 90 to 100

fixed.
it also contains small fixes for 2 formatting issues.
first one is related to output header formating.
when mbstowcs fails because it found invalid multibyte charactes in header name (gettext)
invalid width was computed.
second one is related to 719, with capability to have BE outside of <rpool>/ROOT there was possibility that libbe will return
BE structure which has "be_mntpt" and "be_policy_type" to be NULL, in that case strlen will fail, the fix just check these field for NULL.

#4

Updated by Alexander Stetsenko over 8 years ago

  • Status changed from In Progress to Resolved

Fixed in:

changeset: 13337:d584565e3743
user: Alexander Stetsenko <>
date: Wed Apr 13 13:20:10 2011 +0400
description:
706 beadm should accept 'umount' as well as 'unmount'
Reviewed by: Garrett D'Amore <>
Reviewed by: Dan McDonald <>
Reviewed by: Richard Lowe <>
Approved by: Gordon Ross <>

Also available in: Atom PDF