Project

General

Profile

Bug #7128

git-pbchk fails to detect parent branch

Added by Hans Rosenfeld almost 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
cmd - userland programs
Start date:
2016-06-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Related issues

Is duplicate of illumos gate - Bug #5167: git-pbchk fails to detect parent branchClosed2014-09-15

Actions

History

#1

Updated by Hans Rosenfeld almost 4 years ago

  • Category set to cmd - userland programs
  • Assignee set to Hans Rosenfeld
  • Difficulty changed from Medium to Bite-size

Apparently git-pbchk seems to have a problem with detecting the parent branch. I think this is because the git command used to find the parent branch is split at each whitespace, and one of the arguments is supposed to have a space character in it. Changing that call to pass the git command as a list fixes this.

#2

Updated by Yuri Pankov almost 3 years ago

  • Status changed from New to Closed

Resolved in #5167.

#3

Updated by Yuri Pankov almost 3 years ago

  • Is duplicate of Bug #5167: git-pbchk fails to detect parent branch added

Also available in: Atom PDF