Project

General

Profile

Bug #7143

dbuf_read() creates unnecessary zio_root() for bonus buf

Added by Matthew Ahrens over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2016-06-26
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

dbuf_read() creates a zio_root() to track and wait for all the zio's that may happen as part of this call. However, if the blkptr_t for this buffer is NULL or a hole, we will not create any more zio's, so this zio_root() is unnecessary. This is always the case when calling dbuf_read() on a bonus buffer, because it has no blkptr (it's part of the containing dnode). For workloads that read a lot of bonus buffers (e.g. file creation and removal), creating and destroying these unnecessary zio's can decrease performance by around 3%.

The fix is to only create/destroy the zio_root() in dbuf_read() if the blkptr is not NULL and not a hole.

History

#1

Updated by Matthew Ahrens almost 3 years ago

  • Status changed from New to Closed

duplicate of 8025

Also available in: Atom PDF