Project

General

Profile

Actions

Bug #7151

closed

gnu-emacs-x11 not opening in GUI mode

Added by James Deagle about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
2016-06-29
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

I am unable to open gnu-emacs-x11 in GUI mode from within OpenIndiana Hipster (patched up to latest). I can see it in the Gnome 2 desktop under Applications > Programming, but when I click on Emacs therein, nothing happens.

Below is a list of the Emacs-related packages currently installed in my system.

Cheers,
James


Script started on 29 June, 2016 09:40:46 AM EDT

$ pkg list | grep emacs
editor/gnu-emacs 24.5-2016.0.0.0 i--
editor/gnu-emacs/gnu-emacs-lisp 24.5-2016.0.0.0 i--
editor/gnu-emacs/gnu-emacs-x11 24.5-2016.0.0.0 i--

$ exit

script done on 29 June, 2016 09:41:07 AM EDT

Actions #1

Updated by James Deagle about 5 years ago

I should add that I'm able to open Emacs in console mode, or in gnome-terminal by typing "emacs -nw".

Actions #2

Updated by Aurélien Larcher about 5 years ago

It seems this has to do with missing symbols from X11 libraries (libXpm and libXt).
Can you copy/paste the output of `ldd /usr/bin/emacs-x` ?

Actions #3

Updated by James Deagle about 5 years ago

Thank you for the tip. Here's the ldd output:

Script started on 2 July, 2016 02:22:49 PM EDT
root@darkstar:~# ldd /usr/bin/emacs-x
libtiff.so.5 => /usr/lib/libtiff.so.5
libjpeg.so.62 => /usr/lib/libjpeg.so.62
libpng16.so.16 => /usr/lib/libpng16.so.16
libz.so.1 => /usr/lib/libz.so.1
libm.so.2 => /usr/lib/libm.so.2
libXpm.so.4 => /usr/lib/libXpm.so.4
libXpm.so.4 (SUNW_1.1) => (version not found)
libXaw7.so.7 => /usr/lib/libXaw7.so.7
libXmu.so.4 => /usr/lib/libXmu.so.4
libXt.so.4 => /usr/lib/libXt.so.4
libXt.so.4 (SUNW_1.1) => (version not found)
libXt.so.4 (SUNWprivate) => (version not found)
libSM.so.6 => /usr/lib/libSM.so.6
libICE.so.6 => /usr/lib/libICE.so.6
libX11.so.4 => /usr/lib/libX11.so.4
libXrender.so.1 => /usr/lib/libXrender.so.1
libXft.so.2 => /usr/lib/libXft.so.2
librsvg-2.so.2 => /usr/lib/librsvg-2.so.2
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0
libMagickWand-6.Q16.so.2 => /usr/lib/libMagickWand-6.Q16.so.2
libMagickCore-6.Q16.so.2 => /usr/lib/libMagickCore-6.Q16.so.2
libsec.so.1 => /usr/lib/libsec.so.1
libdbus-1.so.3 => /usr/lib/libdbus-1.so.3
libXrandr.so.2 => /usr/lib/libXrandr.so.2
libXinerama.so.1 => /usr/lib/libXinerama.so.1
libxml2.so.2 => /usr/lib/libxml2.so.2
libresolv.so.2 => /usr/lib/libresolv.so.2
libsocket.so.1 => /usr/lib/libsocket.so.1
libnsl.so.1 => /usr/lib/libnsl.so.1
libncurses.so.5 => /usr/lib/libncurses.so.5
libgconf-2.so.4 => /usr/lib/libgconf-2.so.4
libfreetype.so.6 => /usr/lib/libfreetype.so.6
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1
libgnutls.so.26 => /usr/lib/libgnutls.so.26
libpthread.so.1 => /usr/lib/libpthread.so.1
libc.so.1 => /usr/lib/libc.so.1
liblzma.so.5 => /usr/lib/liblzma.so.5
libXext.so.0 => /usr/lib/libXext.so.0
libxcb.so.1 => /usr/lib/libxcb.so.1
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0
libcairo.so.2 => /usr/lib/libcairo.so.2
libcroco-0.6.so.3 => /usr/lib/libcroco-0.6.so.3
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0
libffi.so.6 => /usr/lib/libffi.so.6
liblcms2.so.2 => /usr/lib/liblcms2.so.2
libfftw3.so.3 => /usr/lib/libfftw3.so.3
libbz2.so.1 => /usr/lib/libbz2.so.1
libltdl.so.7 => /usr/lib/libltdl.so.7
libavl.so.1 => /lib/libavl.so.1
libidmap.so.1 => /usr/lib/libidmap.so.1
libbsm.so.1 => /lib/libbsm.so.1
libmd.so.1 => /lib/libmd.so.1
libmp.so.2 => /lib/libmp.so.2
libORBit-2.so.0 => /usr/lib/libORBit-2.so.0
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0
libexpat.so.1 => /usr/lib/libexpat.so.1
libnettle.so.4 => /usr/lib/libnettle.so.4
libgmp.so.10 => /usr/lib/libgmp.so.10
libhogweed.so.2 => /usr/lib/libhogweed.so.2
libtasn1.so.6 => /usr/lib/libtasn1.so.6
libXau.so.6 => /usr/lib/libXau.so.6
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0
libdl.so.1 => /usr/lib/libdl.so.1
libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1
libxcb-render.so.0 => /usr/lib/libxcb-render.so.0
libGL.so.1 => /usr/lib/libGL.so.1
librt.so.1 => /usr/lib/librt.so.1
libnvpair.so.1 => /lib/libnvpair.so.1
libuutil.so.1 => /lib/libuutil.so.1
libsecdb.so.1 => /lib/libsecdb.so.1
libtsol.so.2 => /lib/libtsol.so.2
libinetutil.so.1 => /lib/libinetutil.so.1
libscf.so.1 => /lib/libscf.so.1
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3
libnvidia-tls.so.1 => /usr/lib/libnvidia-tls.so.1
libnvidia-glcore.so.1 => /usr/lib/libnvidia-glcore.so.1
libgen.so.1 => /lib/libgen.so.1
libsmbios.so.1 => /usr/lib/libsmbios.so.1
libXmuu.so.1 => /usr/lib/libXmuu.so.1
libXevie.so.1 => /usr/lib/libXevie.so.1
libXss.so.1 => /usr/lib/libXss.so.1
root@darkstar:~# exit
exit

script done on 2 July, 2016 02:23:18 PM EDT

Actions #4

Updated by James Deagle about 5 years ago

For good measure, here's the output of "emacs" at the gnome-terminal command prompt:

Script started on 2 July, 2016 02:27:25 PM EDT
root@darkstar:~# emacs
GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.
Error: Unresolved inheritance operation
root@darkstar:~# exit
exit

script done on 2 July, 2016 02:27:31 PM EDT

Actions #5

Updated by Alexander Pyhalov about 5 years ago

  • Status changed from New to Feedback
  • Assignee set to Alexander Pyhalov

Should be fixed by https://github.com/OpenIndiana/oi-userland/pull/2221

The original issue was reported in https://bugs.freedesktop.org/show_bug.cgi?id=6569 , but closed as invalid. While here I've spotted that we miss mapfile for libXt. After adding mapfile and removing -Bdirect from LD_OPTIONS I confirm that emacs-x11 work (as well as xfontsel, which was also broken after libXt update).

Please, install (should be available in repository in several hours) and report if it fixes the issue.

Actions #6

Updated by James Deagle about 5 years ago

Success!

I can now confirm that the issue is now resolved and can therefore be closed. I celebrated with a few rounds of Snake. :)

Cheers,
James

Actions #7

Updated by Alexander Pyhalov about 5 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF