Project

General

Profile

Bug #7161

uefi reboot needs to use acpi_reset_system() if available

Added by Toomas Soome almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
kernel
Start date:
2016-07-02
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

MacBookPro10,1 gets hung on reboot, apparently the issue is that efi_reboot double trap method does not work for this system. However acpi_reset_system() does resolve the issue.

History

#1

Updated by Electric Monk almost 4 years ago

  • % Done changed from 90 to 100
  • Status changed from New to Closed

git commit 7d3321ee71cf6a0555699aa14aad6e5a5ab6bd7c

commit  7d3321ee71cf6a0555699aa14aad6e5a5ab6bd7c
Author: Toomas Soome <tsoome@me.com>
Date:   2016-07-07T19:57:42.000Z

    7161 uefi reboot needs to use acpi_reset_system() if available
    Reviewed by: Andrew Stormont <andyjstormont@gmail.com>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF