Project

General

Profile

Bug #7165

add intermediate SUNW_1.22.7 symbol version to libc for backward binary support including latest s10 release

Added by Richard PALO about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2016-07-03
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

as discovered with the latest SS12. 5, there has been an intermediate SUNW_1.22.7 symbol version
added in Solaris that is trivial for illumos to support via the attached patch.

Simple testing done:

richard@omnis:/home/richard/src/tasprintf$ cat tasprintf.c 
#include <stdio.h>
#include <stdlib.h>

int
main(int argc, char *argv[])
{
    char *buffer;
    int len = 0;

    len = asprintf(&buffer, "Hello World");
    if (len < 0) {
        perror("asprintf");
        return (len);
    }

    printf("%s(len=%d)\n", buffer, len);
    free(buffer);

    return (0);
}
richard@omnis:/home/richard/src/tasprintf$ gcc -Wall -o tasprintf tasprintf.c
richard@omnis:/home/richard/src/tasprintf$ gobjdump -T tasprintf |grep asprintf
tasprintf:     file format elf32-i386-sol2
08050b04      DF *UND*    00000000  SUNW_1.23   asprintf
richard@omnis:/home/richard/src/tasprintf$ /opt/SolarisStudio12.5Beta-solaris-x86-bin/bin/cc tasprintf.c 
ld.so.1: iropt: fatal: libc.so.1: version 'SUNW_1.22.7' not found (required by file /opt/SolarisStudio12.5Beta-solaris-x86-bin/lib/compilers/bin/iropt)
ld.so.1: iropt: fatal: libc.so.1: open failed: No such file or directory
cc: Warning: Static error checker encountered an unexpected error.
richard@omnis:/home/richard/src/tasprintf$ ./tasprintf 
Hello World(len=11)
richard@omnis:/home/richard/src/tasprintf$ /opt/SolarisStudio12.5Beta-solaris-x86-bin/bin/cc tasprintf.c 
ld.so.1: iropt: fatal: libc.so.1: version 'SUNW_1.22.7' not found (required by file /opt/SolarisStudio12.5Beta-solaris-x86-bin/lib/compilers/bin/iropt)
ld.so.1: iropt: fatal: libc.so.1: open failed: No such file or directory
cc: Warning: Static error checker encountered an unexpected error.
richard@omnis:/home/richard/src/tasprintf$ export LD_LIBRARY_PATH_64=~/src/illumos-gate/proto/root_i386/lib/amd64/
richard@omnis:/home/richard/src/tasprintf$ export LD_LIBRARY_PATH_32=~/src/illumos-gate/proto/root_i386/lib
richard@omnis:/home/richard/src/tasprintf$ ./tasprintf 
Hello World(len=11)
richard@omnis:/home/richard/src/tasprintf$ /opt/SolarisStudio12.5Beta-solaris-x86-bin/bin/cc tasprintf.c 
richard@omnis:/home/richard/src/tasprintf$


Files


Related issues

Is duplicate of illumos gate - Feature #5709: Add binary compatibility with Solaris 10 update 10Closed2015-03-13

Actions

History

#2

Updated by Andrew Stormont about 4 years ago

  • Is duplicate of Feature #5709: Add binary compatibility with Solaris 10 update 10 added
#3

Updated by Richard PALO about 4 years ago

sorry Andy.
Why in the hell didn't your patchset get committed. It looks great. +1

#4

Updated by Andrew Stormont about 4 years ago

I was asked to verify the semantics of our asprintf, fdatasync, smt_pause and vasprintf functions do not differ from the versions in Solaris 10 update 10 before the changes could be integrated. This is not something I was able to do definitively.

#5

Updated by Richard PALO about 4 years ago

Andrew Stormont wrote:

I was asked to verify the semantics of our asprintf, fdatasync, smt_pause and vasprintf functions do not differ from the versions in Solaris 10 update 10 before the changes could be integrated. This is not something I was able to do definitively.

well, let's simplify.
https://docs.oracle.com/cd/E23823_01/html/816-5168/asprintf-3c.html
https://docs.oracle.com/cd/E26505_01/html/816-5171/fdatasync-3rt.html
https://docs.oracle.com/cd/E23823_01/html/816-5168/smt-pause-3c.html
https://docs.oracle.com/cd/E23823_01/html/816-5168/vasprintf-3c.html

looks good to me!

#6

Updated by Electric Monk about 2 years ago

  • Status changed from New to Closed

git commit c6fe8850c7ff4c85074c93430743b146d8133436

commit  c6fe8850c7ff4c85074c93430743b146d8133436
Author: Alexander Pyhalov <apyhalov@gmail.com>
Date:   2018-08-26T00:48:14.000Z

    5709 Add binary compatibility with Solaris 10 update 10
    Reviewed by: Andy Fiddaman <omnios@citrus-it.co.uk>
    Reviewed by: Toomas Some <tsoome@me.com>
    Reviewed by: Gordon Ross <gordon.w.ross@gmail.com>
    Approved by: Joshua M. Clulow <josh@sysmgr.org>

Also available in: Atom PDF