Project

General

Profile

Actions

Bug #7170

closed

ENABLE_PERL64 multiarch builds

Added by Richard PALO almost 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2016-07-05
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

illumos-gate needs to support distros with multiarch perl implementations such as omnios.

illumos-omnios has done the primary work, but in addition shadow compiling needs to
have E_ATTRIBUTE_UNKNOWN and E_ATTRIBUTE_PARAM_UNDEFINED stiffled
in absence of the perl patch to sunpro when primarily built with gcc (patchset used
in OI/hipster but not yet, for example, in omnios itself).

This is particularly useful for gate developers using omnios when wishing to ONU and
actually use their, or others, work (and is frequently requested by advocates prior to RTI)


Related issues

Related to illumos gate - Feature #7661: illumos should provide 64bit perl modulesClosedAndrew Stormont2016-12-11

Actions
Actions #1

Updated by Andrew Stormont almost 3 years ago

  • Related to Feature #7661: illumos should provide 64bit perl modules added
Actions #2

Updated by Andrew Stormont almost 3 years ago

  • Status changed from New to Closed

This was addressed in 7661.

Actions

Also available in: Atom PDF