Project

General

Profile

Bug #7182

panic when booting with KVM SATA CDROM

Added by Dillon Amburgey almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2016-07-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

This is when booting from http://dlc.openindiana.org/isos/hipster/OI-hipster-text-20160421.iso (MD5 9b5ff26ca85f065e03751290baf25e78 OI-hipster-text-20160421.iso).

cat /etc/centos-release
CentOS Linux release 7.2.1511 (Core)

rpm -qid qemu-kvm
Name : qemu-kvm
Epoch : 10
Version : 1.5.3
Release : 105.el7_2.4
Architecture: x86_64
Install Date: Thu 19 May 2016 12:10:07 PM EDT
Group : Development/Tools
Size : 5924061
...

This issue does not seem to reproduce 100% of the time.

Loading kmdb...
SunOS Release 5.11 Version illumos-f83b46b 64-bit
Copyright (c) 1983, 2010, Oracle and/or its affiliates. All rights reserved.
NOTICE: vioif0: Got MAC address from host: 52:54:0:e5:70:7b
NOTICE: Csum enabled.
NOTICE: LSO enabled

panic[cpu3]/thread=ffffff001ee6dc40: BAD TRAP: type=e (#pf Page fault) rp=ffffff001ee6d8b0 addr=40 occurred in module "ahci" due to a NULL pointer dereference

sched: #pf Page fault
Bad kernel fault at addr=0x40
pid=0, pc=0xfffffffff8ac36c4, sp=0xffffff001ee6d9a0, eflags=0x10286
cr0: 8005003b<pg,wp,ne,et,ts,mp,pe> cr4: 6f8<xmme,fxsr,pge,mce,pae,pse,de>
cr2: 40cr3: d000000cr8: c

        rdi: ffffff04e8b332c0 rsi:                0 rdx:                1
        rcx:         fffffffe  r8:                0  r9:               10
        rax:               3d rbx: ffffff04e8b332c0 rbp: ffffff001ee6d9c0
        r10: ffffff001ee6d840 r11:                0 r12:                0
        r13:                0 r14:                0 r15:                0
        fsb:                0 gsb: ffffff04e880e080  ds:               4b
         es:               4b  fs:                0  gs:              1c3
        trp:                e err:                0 rip: fffffffff8ac36c4
         cs:               30 rfl:            10286 rsp: ffffff001ee6d9a0
         ss:               38

Warning - stack not written to the dump buffer
ffffff001ee6d790 unix:die+df ()
ffffff001ee6d8a0 unix:trap+dd8 ()
ffffff001ee6d8b0 unix:_cmntrap+e6 ()
ffffff001ee6d9c0 ahci:ahci_add_doneq+14 ()
ffffff001ee6da60 ahci:ahci_mop_commands+148 ()
ffffff001ee6db00 ahci:ahci_fatal_error_recovery_handler+241 ()
ffffff001ee6db60 ahci:ahci_events_handler+da ()
ffffff001ee6dc20 genunix:taskq_thread+2d0 ()
ffffff001ee6dc30 unix:thread_start+8 ()

panic: entering debugger (no dump device, continue to reboot)

Welcome to kmdb
kmdb: unable to determine terminal type: assuming `vt100'
Loaded modules: [ scsi_vhci stmf_sbd crypto mac cpc uppc neti ufs unix mpt zfs 
krtld s1394 sata apix uhci pmcs hook genunix idm ip usba specfs pcplusmp md 
random mm cpu.generic arp mpt_sas stmf emlxs sockfs ]
[3]> ::stacks -m ahci
THREAD           STATE    SOBJ                COUNT
ffffff001eb32c40 SLEEP    MUTEX                   1
                 swtch+0x82
                 turnstile_block+0x21a
                 mutex_vector_enter+0x3a3
                 ahci`ahci_port_intr+0x76
                 ahci`ahci_intr+0xb8
                 av_dispatch_autovect+0x91
                 dispatch_hardint+0x36

ffffff0020714c40 ONPROC   <NONE>                  1
                 pcplusmp`apic_send_EOI+0x1d
                 hilevel_intr_prolog+0x3d
                 do_interrupt+0x120
                 _interrupt+0xba
                 mutex_delay_default+7
                 mutex_vector_enter+0xc5
                 cv_wait+0x7c
                 ahci`ahci_do_sync_start+0x1bb
                 ahci`ahci_tran_start+0x5a6
                 sata`sata_fetch_device_identify_data+0x110
                 sata`sata_identify_device+0x23
                 sata`sata_probe_device+0x29d
                 sata`sata_add_device+0x8b
                 sata`sata_probe_ports+0x1f6
                 sata`sata_hba_attach+0x30f
                 ahci`ahci_register_sata_hba_tran+0x148
                 ahci`ahci_attach+0x5d4
                 devi_attach+0x92
                 attach_node+0xa7
                 i_ndi_config_node+0x7d
                 i_ddi_attachchild+0x48
                 devi_attach_node+0x5e
                 config_immediate_children+0xbf
                 devi_config_common+0xd9
                 mt_config_thread+0x58
                 thread_start+8

ffffff001ee6dc40 PANIC    <NONE>                  1
                 avl_find+0x72
                 as_segat+0x3d
                 as_fault+0x4e7
                 die+0xdf
                 trap+0xdd8
                 0xfffffffffb8001d6
                 ahci`ahci_add_doneq+0x14
                 ahci`ahci_mop_commands+0x148
                 ahci`ahci_fatal_error_recovery_handler+0x241
                 ahci`ahci_events_handler+0xda
                 taskq_thread+0x2d0
                 thread_start+8


Related issues

Is duplicate of illumos gate - Bug #7075: ahci: NULL pointer dereference in ahci_add_doneq()New2016-06-06

Actions

History

#1

Updated by Dillon Amburgey almost 4 years ago

This seems to only happen when I have the VM assigned multiple (2 will do) cores

#2

Updated by Marcel Telka over 3 years ago

  • Category set to driver - device drivers
  • Status changed from New to Closed

A duplicate of #7075.

#3

Updated by Marcel Telka over 3 years ago

  • Is duplicate of Bug #7075: ahci: NULL pointer dereference in ahci_add_doneq() added

Also available in: Atom PDF