Project

General

Profile

Bug #7188

Panic in rfs4_compound_kstat_res

Added by Jorgen Lundman over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
nfs - NFS server and client
Start date:
2016-07-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

SunOS nfs02 5.11 omnios-r151018-ae3141d i86pc i386 i86pc

Issued command "zfs share -a" and triggered panic.

BAD TRAP: type=e (#pf Page fault) rp=ffffff02e395e6b0 addr=90 occurred in module "nfssrv" due to a NULL pointer dereference
 nfsd:
 #pf Page fault
 Bad kernel fault at addr=0x90
 pid=708, pc=0xfffffffff829ed9d, sp=0xffffff02e395e7a0, eflags=0x10246
 cr0: 8005003b<pg,wp,ne,et,ts,mp,pe> cr4: 1406f8<smep,osxsav,xmme,fxsr,pge,mce,pae,pse,de>
 cr2: 90
 cr3: 5d1c3ee000
 cr8: 0
   rdi: ffffffffc01b28a8 rsi:                1 rdx:               a8
   rcx:    8  r8:                0  r9:         97d7be6d
   rax:    0 rbx:                0 rbp: ffffff02e395e7f0
   r10:    0 r11:                3 r12:                0
   r13: ffffff02e395e810 r14: ffffff6989d6e500 r15:               16
   fsb:    0 gsb: ffffff6472187540  ds:               4b
    es:   4b  fs:                0  gs:              1c3
   trp:    e err:                0 rip: fffffffff829ed9d
    cs:               30 rfl:            10246 rsp: ffffff02e395e7a0
    ss:               38
  ffffff02e395e590 unix:die+df ()
  ffffff02e395e6a0 unix:trap+dd8 ()
  ffffff02e395e6b0 unix:_cmntrap+e6 ()
  ffffff02e395e7f0 nfssrv:rfs4_compound_kstat_res+bd ()
  ffffff02e395e8b0 nfssrv:rfs4_dispatch+1b8 ()
  ffffff02e395ec20 nfssrv:common_dispatch+b2f ()
  ffffff02e395ec40 nfssrv:rfs_dispatch+2d ()
  ffffff02e395ed20 rpcmod:svc_getreq+1c1 ()
  ffffff02e395ed90 rpcmod:svc_run+e0 ()
  ffffff02e395edd0 rpcmod:svc_do_run+8e ()
  ffffff02e395eec0 nfs:nfssys+111 ()
  ffffff02e395ef10 unix:brand_sys_sysenter+1c9 ()

rw-r--r- 1 root root 11805196288 Jul 18 02:35 vmdump.0

After boot, services are back.


Related issues

Is duplicate of illumos gate - Bug #6472: Panic in rfs4_compound_kstat_res()ClosedMarcel Telka2015-11-22

Actions
#1

Updated by Igor Kozhukhov over 4 years ago

duplicate to: 6472 Panic in rfs4_compound_kstat_res()

#2

Updated by Jorgen Lundman over 4 years ago

Igor Kozhukhov wrote:

duplicate to: 6472 Panic in rfs4_compound_kstat_res()

Ah my apologies for failing to search properly, it was a long night.

This panic has happened twice more since then, on the same nfs02 (out of 3) which is peculiar.

#3

Updated by Marcel Telka over 4 years ago

  • Is duplicate of Bug #6472: Panic in rfs4_compound_kstat_res() added
#4

Updated by Marcel Telka over 4 years ago

  • Category changed from kernel to nfs - NFS server and client
  • Status changed from New to Closed

Also available in: Atom PDF