Project

General

Profile

Feature #7211

Update Ekiga to 4.0.1

Added by r a over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
2016-07-30
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Medium
Tags:

Description

The current release of Ekiga 3.2.7 in the OpenIndiana distribution is v3.2.7 from 2009 while the latest stable is v4.0.1 released in 2013.
If this upgrade is considered, can you check that the processing of USB Webcam video stream is working.
With the 3.2.7 release I found the video unusable and had to just use audio


Files

ekiga-build.txt (7.6 KB) ekiga-build.txt r a, 2016-07-24 11:50 AM

Subtasks

Feature #7244: Bump ptlib to 2.10.11ResolvedOI Userland

Actions
Feature #7245: Bump opal to 3.10.10ResolvedOI Userland

Actions

History

#1

Updated by Aurélien Larcher over 3 years ago

  • Category set to OI-Userland
  • Assignee set to OI Userland
  • Target version set to 2017.04
#2

Updated by Aurélien Larcher over 3 years ago

Could you please review the dependencies:
- list them with version numbers in the ticket,
- indicate which libraries need to be added or bumped,
- provide information on possible issues.

Whenever action is required open a new ticket as subtask of this one.

#3

Updated by Aurélien Larcher over 3 years ago

  • Subject changed from Can Ekiga be upgraded to v4.0.1 which was released in 2013 to Update Ekiga to 4.0.1
#4

Updated by r a over 3 years ago

Aurélien Larcher wrote:

Could you please review the dependencies:
- list them with version numbers in the ticket,
- indicate which libraries need to be added or bumped,
- provide information on possible issues.

Whenever action is required open a new ticket as subtask of this one.

WANTLIB = SDL X11 Xcomposite Xcursor Xdamage Xext Xfixes Xi Xinerama
WANTLIB += Xrandr Xrender Xv asn1 atk-1.0 boost_signals-mt c cairo
WANTLIB += camel-1.2 com_err crypto db dbus-1 dbus-glib-1 ebackend-1.2
WANTLIB += ebook-1.2 ebook-contacts-1.2 edata-book-1.2 edataserver-1.2
WANTLIB += expat ffi fontconfig freetype gck-1 gcr-base-3 gcrypt
WANTLIB += gdk-x11-2.0 gdk_pixbuf-2.0 gio-2.0 glib-2.0 gmodule-2.0
WANTLIB += gobject-2.0 gpg-error graphite2 gssapi gthread-2.0
WANTLIB += gtk-x11-2.0 harfbuzz krb5 lber-2.4
WANTLIB += ldap-2.4 ldap_r-2.4 m notify nspr4 nss3 nssutil3 opal
WANTLIB += p11-kit pango-1.0 pangocairo-1.0 pangoft2-1.0 pcre
WANTLIB += pixman-1 plc4 plds4 png pt pthread pthread-stubs sasl2
WANTLIB += secret-1 smime3 sndio softokn3 soup-2.4 speexdsp sqlite3
WANTLIB += ssl ssl3 stdc
+ usbhid xcb xcb-render xcb-shm xml2
WANTLIB += heimbase roken wind
WANTLIB += z

MODULES= devel/gettext \
x11/gnome \
devel/gconf2

LIB_DEPENDS= net/opal>=3.10.10 \
devel/sdl \
databases/evolution-data-server \
devel/libnotify \
devel/boost \
x11/gtk+2

#5

Updated by r a over 3 years ago

r a wrote:

Aurélien Larcher wrote:

Could you please review the dependencies:
- list them with version numbers in the ticket,
- indicate which libraries need to be added or bumped,
- provide information on possible issues.

Whenever action is required open a new ticket as subtask of this one.

WANTLIB = SDL X11 Xcomposite Xcursor Xdamage Xext Xfixes Xi Xinerama
WANTLIB += Xrandr Xrender Xv asn1 atk-1.0 boost_signals-mt c cairo
WANTLIB += camel-1.2 com_err crypto db dbus-1 dbus-glib-1 ebackend-1.2
WANTLIB += ebook-1.2 ebook-contacts-1.2 edata-book-1.2 edataserver-1.2
WANTLIB += expat ffi fontconfig freetype gck-1 gcr-base-3 gcrypt
WANTLIB += gdk-x11-2.0 gdk_pixbuf-2.0 gio-2.0 glib-2.0 gmodule-2.0
WANTLIB += gobject-2.0 gpg-error graphite2 gssapi gthread-2.0
WANTLIB += gtk-x11-2.0 harfbuzz krb5 lber-2.4
WANTLIB += ldap-2.4 ldap_r-2.4 m notify nspr4 nss3 nssutil3 opal
WANTLIB += p11-kit pango-1.0 pangocairo-1.0 pangoft2-1.0 pcre
WANTLIB += pixman-1 plc4 plds4 png pt pthread pthread-stubs sasl2
WANTLIB += secret-1 smime3 sndio softokn3 soup-2.4 speexdsp sqlite3
WANTLIB += ssl ssl3 stdc
+ usbhid xcb xcb-render xcb-shm xml2
WANTLIB += heimbase roken wind
WANTLIB += z

MODULES= devel/gettext \
x11/gnome \
devel/gconf2

LIB_DEPENDS= net/opal>=3.10.10 \
devel/sdl \
databases/evolution-data-server \
devel/libnotify \
devel/boost \
x11/gtk+2

When I attempted to build this myself I build failed due to a problem with xgettext as it does not support the --version option.

#6

Updated by Aurélien Larcher over 3 years ago

Hi,
we have two version of xgettext:

1) /usr/bin/xgettext from pkg:/text/locale
2) /usr/gnu/bin/xgettext from pkg:/text/gnu-gettext

You can prepend /usr/gnu/bin to PATH to pick the GNU version.

#7

Updated by Aurélien Larcher over 3 years ago

  • Status changed from New to Resolved
  • Tags deleted (needs-triage)

Also available in: Atom PDF