Project

General

Profile

Actions

Bug #724

closed

rrdtool doesnt work with perl

Added by matthew lagoe almost 11 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Desktop (JDS)
Target version:
Start date:
2011-02-10
Due date:
2011-09-14
% Done:

0%

Estimated time:
8.00 h
Difficulty:
Bite-size
Tags:
perl

Description

It says it does and that it should but it doesnt

,5.11-0.148:20101125T004700Z

Actions #1

Updated by Albert Lee over 10 years ago

  • Category changed from PKG (Image Packaging System) to 10
  • Status changed from New to Feedback
  • Priority changed from High to Low

Please describe the problem in more detail, including any messages and how to reproduce them.

Actions #2

Updated by matthew lagoe over 10 years ago

simply the package says that its built with perl support however it does not have it.

Actions #3

Updated by Chris Jordan over 10 years ago

  • Assignee set to OI SFW
  • Difficulty set to Medium
  • Tags set to perl

The problem appears to be that rrdtool was not compiled to build the Perl modules required for Perl support, or else they were not included in the package for some reason:

bash-4.0$ pkg contents rrdtool | grep pm
usr/share/rrdtool/examples/rrdcached/RRDCached.pm

So if I try and run one of the rrdtool example perl scripts I get an error:

bash-4.0$ /usr/share/rrdtool/examples/4charts.pl
Can't locate RRDs.pm in @INC (@INC contains: /usr/lib/perl /usr/perl5/5.8.4/lib/i86pc-solaris-64int /usr/perl5/5.8.4/lib /usr/perl5/site_perl/5.8.4/i86pc-solaris-64int /usr/perl5/site_perl/5.8.4 /usr/perl5/site_perl /usr/perl5/vendor_perl/5.8.4/i86pc-solaris-64int /usr/perl5/vendor_perl/5.8.4 /usr/perl5/vendor_perl .) at /usr/share/rrdtool/examples/4charts.pl line 6.
BEGIN failed--compilation aborted at /usr/share/rrdtool/examples/4charts.pl line 6.

If I use pkgtool to build rrdtool from spec-files-extra then it does build and install those modules, so perhaps it's easy to fix?

bash-4.0$ pkg contents SFErrdtool | grep pm
usr/perl5/vendor_perl/5.8.4/RRDp.pm
usr/perl5/vendor_perl/5.8.4/i86pc-solaris-64int/RRDs.pm
usr/share/rrdtool/examples/rrdcached/RRDCached.pm

Actions #4

Updated by Jon Tibble over 10 years ago

  • Category changed from 10 to Desktop (JDS)
  • Assignee changed from OI SFW to OI JDS
Actions #5

Updated by Guido Berhörster over 10 years ago

Perl, Python, and Ruby bindings are intentionally disabled because they fail to build.

Actions #6

Updated by Ken Mays about 10 years ago

  • Due date set to 2011-09-14
  • Status changed from Feedback to Closed
  • Target version set to oi_151_stable
  • Estimated time set to 8.00 h
  • Difficulty changed from Medium to Bite-size

Matthew - The RRD*.pm perl modules are optional - not a requirement for the Oracle-based IPS packages. This can be a feature request but we already provide this in the SFE-extras spec. Closing ticket.

Actions

Also available in: Atom PDF