Feature #726

Virtual consoles should be enabled by default

Added by Matt Wilby about 7 years ago. Updated 9 days ago.

Status:ClosedStart date:2011-02-13
Priority:NormalDue date:
Assignee:OI Caiman% Done:

0%

Category:Caiman (Installer)
Target version:-
Difficulty:Medium Tags:needs-triage

Description

Very useful feature on Linux. Would be nice to see in OI.

History

#1 Updated by Garrett D'Amore about 7 years ago

I think the problem is that the code has problems -- there may be logindevperm problems, and I think overall the code for VC isn't 100% complete and bug free.

#2 Updated by Jim Klimov about 7 years ago

I second this motion that virtual consoles should be available.

Can't say regarding "bug-free", but they did work acceptably in SXCE when the feature was introduced (integrated into downloadable ISOs). They do not work for me now on oi_148a.

It seems I can switch to another console, but there's nothing there except the blinking cursor, and I can't successfully switch back to the original console. Also I can't switch between text and X11 consoles (I can drop from X11 to the blinking cursor screen, and never go back). The situation makes the machine console nearly useless after attempts to switch "virtual terminals", however I can SSH from another machine and restart "console-login" or "gdm" services as appropriate to get the interactive console back :)

I have roughly traced the SMF scripts and the programs they call, it seems they do what they should. So it may be a permissions/RBAC problem...

On a side note, "xconsole" occasionally fails to work and attach to console (from a root X11 session via "user -> su - root -> export DISPLAY=:0 ; xconsole"). I am not sure if this is anyhow related, maybe merely a coincidence.

//Jim Klimov

#3 Updated by Jim Klimov about 7 years ago

Also, and I'm not sure how related, occasionally when the keyboard is not touched for a few minutes, the screen goes blank (but not off as expected for a screensaver) and the X11 session falls back to text mode and never returns into graphics. Text mode console is also not available at that moment, so I have to either reset the machine or SSH into it to restart the console services.

It seems to have been caused by screensaver; at least disabling it stopped this type of problem for me.

The computer has an ATI Radeon graphics card, but I think I still had the default "vga" driver at that time.

#4 Updated by Julian Wiesener almost 7 years ago

  • Target version deleted (oi_151)
  • Assignee set to OI Caiman
  • Category set to Caiman (Installer)
  • Tags set to needs-triage
  • Difficulty set to Medium

not for 151

#5 Updated by Ken Mays over 6 years ago

  • Status changed from New to Closed

Closed. Work out of scope for core oi-dev. Moving request to SFE & ISVs for further review.

#6 Updated by Paul Walker about 2 months ago

On the off chance that you need to download anything of any kind of online marketplace, you require an internet connection. As the virtual console games are not as of now introduced to your Wii, assignment writers they have to originate from some place. Clearly this wouldn't occur with no internet connection.

#7 Updated by Jacob Arch about 1 month ago

If you need to download any type of online market, you need an internet connection. Since virtual console games are not introduced to you now do my assignment , they must come from somewhere. Obviously, this will not happen without an internet connection.

#8 Updated by Lisa Ruxandra 25 days ago

Your consideration is exceptional. It shows up you have the rich finding out about this domain. Allow me to tell that you have created an astounding article. Keep up the immense composed work. Assignment Help UK

#9 Updated by Selina Jasmin 9 days ago

In case you have to download anything of any sort of online commercial center, you require a web association. As the virtual reassure recreations are not starting at now acquainted with your Wii, task essayists they need to begin from somewhere. Unmistakably, this wouldn't happen with no web association. online assignments help

Also available in: Atom